cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

Workflows do not continue anymore after Nintex Workflow 2013 update

Hi,

I seem to have the same problem updating Nintex Workflow again. The last time i thought it would occur only this single time but as i find now, I was wrong.

I just updated my Nintex Workflow 2013 from Version 3.1.1.0 to Version 3.1.8.0. Yes this is a big gap in Versions but this is not the source of the problem I think (because i had the same problem when i updated Nintex the last time and the Version gap was quite small). I used the nintex tutorial for updating Nintex Workflow so i also did an iisreset and reset the timer Service.

So what is the problem?

After the update I cannot continue running Workflows. Finishing a workflow task from a running workflow does not continue the workflow. When I then try to finish the task again SharePoint says that the task is locked by a running workflow (in ULS log). I tried activating the Workflow timer Job again and also the script suggested in the thread  Task Lock - Task is locked by a running workflow and cannot be edited, but both Solutions didnt work for me. When I use the script the task gets unlocked and the next time I try to finish it there is no error concerning a locked task, but the workflow does still not continue... It seems the workflow does not get the information from the task being finished. Maybe ID problems!?

If I start a new workflow everything works like expected. I only have problems with the workflows that were running before the update.

Do you guys have any further suggestions/ideas? I would really appreciate it.

Thanks in advance!

Henrik

Labels: (1)
0 Kudos
Reply
1 Reply
Not applicable

Re: Workflows do not continue anymore after Nintex Workflow 2013 update

Additional Information: I just had a look into the Nintex Workflow database and i found that there is no workflow Task in the dbo.WorkflowInstanceTasks table that corresponds to the workflow I try to continue. But I see the Task in my SahrePoint Task list and i can open and "action" the Task. Seems like the update deleted the Task or changed IDs so i cannot find the corresponding Task with the correct WorkflowInstanceId.

0 Kudos
Reply