cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Nintex Newbie

Workflow task form loads in default SharePoint style for some users

Jump to solution

Hi - I've got a list with a workflow on it that creates a FlexiTask. I've modified the task form using Nintex Forms.

 

When some of my users open the task form, it loads in the default SharePoint style and the formatting is all wonky. If I open the exact same link the Nintex version of the form loads for me.

 

I believe the problem is related to permissions. If I log into a different computer the form still loads correctly for me. I created a test user and assigned them permissions to the source list and ensured they have permissions to the workflows tasks list but the form doesn't load correctly.

 

Not sure what I'm missing? Any pointers appreciated!

 

Thanks,

Jumpin'

Labels: (2)
0 Kudos
Reply
6 Replies
Highlighted
Nintex Employee
Nintex Employee

Re: Workflow task form loads in default SharePoint style for some users

Jump to solution
Hi,
The user has permissions to the list, what permissions do they have to the site?
0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Workflow task form loads in default SharePoint style for some users

Jump to solution

Hi Simon,

 

I gave my test user full permissions to the site in question but I get the same result.

 

I also opened the browser's debugging tools, did a hard refresh and all http requests return a 200 status.

 

Thanks
Gareth

0 Kudos
Reply
Highlighted
Nintex Employee
Nintex Employee

Re: Workflow task form loads in default SharePoint style for some users

Jump to solution
Any errors in the browser console?
0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Workflow task form loads in default SharePoint style for some users

Jump to solution

Only one. When I Googled it, I was lead to a StackExchange thread which suggested it was a Chrome specific error related to SharePoint.

 

Sure enough, I loaded the form up in IE and I don't get the error, so it doesn't appear related.

 

I don't think it will help, but the error was:

 

Uncaught TypeError: Cannot read property 'parentElement' of null
at RTE.Canvas.checkCurrentFocus

 

If I open the URI the error is referencing I'm able to load it as my test user so it's not a read issue. Just a bug with Chrome/SharePoint.

 

This is the SE thread:

 

https://sharepoint.stackexchange.com/questions/38370/a-is-null-error-in-vanilla-sp2010-install

0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Workflow task form loads in default SharePoint style for some users

Jump to solution

It's 9PM where I am so I'll open a support case in the morning and report back once I have it resolved.

0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Workflow task form loads in default SharePoint style for some users

Jump to solution

So as always with these things, it was something simple. My form references a CSS file hosted on my site that was checked-out. Once I checked the file in the form loaded as expected.

 

Thank you for your help, Simon.

View solution in original post

Reply