cancel
Showing results for 
Search instead for 
Did you mean: 
aak1
Nintex Newbie

Workflow is showing that list fields are required even though they're not

I have a number of lists in a 2013 environment. I had two fields set as required, but I removed that requirement so all fields are optional. I want to create a workflow that creates an item in these lists, but whenever i use the create item action, it is showing those two fields as required. They are not site content types. I am also not using any custom forms. I tried deleting and recreating the workflow, but am still not having any luck. Any help would be appreciated.

Labels: (1)
0 Kudos
Reply
4 Replies
eiben
Nintex Newbie

Re: Workflow is showing that list fields are required even though they're not

Did you check wether those fields are marked as required using the OOTB sharepoint UI?

0 Kudos
Reply
praios81
Nintex Newbie

Re: Workflow is showing that list fields are required even though they're not

Do you have "manage content types" option enabled for this list? If so, can you try to disable the option and check if SharePoint counts the columns themselves as required?

 

I had that once when working with multiple content types on a list and I removed a required field. But sharepoint won't let me leave the column blank until I disabled content type management leading to the final required-field-option. Afterwards everything was fine.

 

Best regards

Enrico

0 Kudos
Reply
aak1
Nintex Newbie

Re: Workflow is showing that list fields are required even though they're not

Okay, so I'm not sure what the problem was, but when I came in this morning, everything seems normal now. Maybe there was a timer job that needed to run or something?

0 Kudos
Reply
eiben
Nintex Newbie

Re: Workflow is showing that list fields are required even though they're not

Actually - I would doubt that. AFAIK there are no timerjobs involved when changing settings in lists.

 

But anyway - glad it works now.

0 Kudos
Reply