cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
thzu
Nintex Newbie

Workflow errors but seems to work fine

Hi there,

I have a weird problem: sometimes one of my workflows errors, but all the fields are 'green' when viewing the workflow history.

I get this error: The workflow could not update the item, possibly because one or more columns for the item require a different type of information.

My workflow in particular:

I ended the workflow and started it again and then it worked without an error. On other items this error happens too but very rarely.

I cannot find a mistake either.

What my workflow does:

1. Check if title= title of an item from another library with with ID xxx

AND

Check if description= description of an item from another library with same ID xxx

2. if one of them are not equal, update the item in the other library. (title and description).

When the error occurs the workflow is going to step 2 even though the title and description are equal. When I start the workflow again the workflow does not try to update the item and no error occurs.

Any ideas how to troubleshoot this issue in general?

0 Kudos
Reply
10 Replies
Automation Master
Automation Master

Re: Workflow errors but seems to work fine

Maybe this is the root cause of your issue: https://community.nintex.com/thread/14238-update-task-status

0 Kudos
Reply
cholslin
Nintex Newbie

Re: Workflow errors but seems to work fine

The error you are seeing means SharePoint is rejecting the update. One or more of the values you are trying to set are not valid for the field type. For example, if you update a hyperlink column with plain text instead of an actual hyperlink, SharePoint rejects the update and you'd get this exact same error. This is a run-time error; the workflow designer won't catch things like this.

If you are only updating the Title and Description fields on the item in the other library, check the constraints on those fields in the Document Library settings menu.

  1. Are they mandatory?
  2. What is the maximum length?
  3. What type of content is expected? Plain text, formatted text?

Make sure your update item workflow action isn't violating the constraints on the columns. It also helps to make sure that the item in the other list your workflow is trying to update actually exists.

0 Kudos
Reply
thzu
Nintex Newbie

Re: Workflow errors but seems to work fine

Hi ‌,

Title: one is the default SharePoint Column, one is a single-line-of-text variable

Desription: both 6 lines, one Plain text (in item library) and the other one is in a doc library and there are no further settings..

Could one of them cause the error?

0 Kudos
Reply
Automation Master
Automation Master

Re: Workflow errors but seems to work fine

Hi again,

Did you check my suggested link?

What you described is a known bug in SP when you try to update an item with a workflow in another list.

When you do not update the item, you never have the error and when you update it, sometimes, you have it.

Did you have the option in the target list: Update item when item is created or updated?

Regards,

Christophe

0 Kudos
Reply
burkslm
Nintex Newbie

Re: Workflow errors but seems to work fine

I've seen this occur before. One thing I have noticed is that another user was updating the item the same time as I was. I don't know if that was the problem or not but it sure was funny there were two users making updates.

0 Kudos
Reply
thzu
Nintex Newbie

Re: Workflow errors but seems to work fine

Hi Christophe Raucq‌,

I don't know what is meant by

Christophe Raucq schrieb:

Maybe this is the root cause of your issue: https://community.nintex.com/thread/14238-update-task-status

"as workflow owner and published with a farm account with the same issue" (question)

and "You need to do all in the workflow in the Leave Request list." (answer) ... :/

0 Kudos
Reply
Automation Master
Automation Master

Re: Workflow errors but seems to work fine

Hi thzu thzu,

Do you have a workflow on another list updating the list where you have this error?

Do you have two workflows running on this list?

Regards,

Christophe

0 Kudos
Reply
kelliganp
Nintex Newbie

Re: Workflow errors but seems to work fine

Is this a consistent issue on any of your workflows? If so, try adding a pause for 5 min at the end and see if the issue goes away. 

0 Kudos
Reply
cholslin
Nintex Newbie

Re: Workflow errors but seems to work fine

You mention this being a known bug in SP. Do you happen to have a link to this either on TechNet or MSDN?

0 Kudos
Reply