cancel
Showing results for 
Search instead for 
Did you mean: 
marekan
Nintex Newbie

Workflow Web Request returning The request was aborted: Could not create SSL/TLS secure channel.

Jump to solution

Hi all,

anyone ever done web request to Cisco Identity Services Engine

https://www.cisco.com/c/en/us/td/docs/security/ise/2-0/api_ref_guide/api_ref_book/ise_api_ref_guest....

?

I have web request in the workflow which is supposed to create the user account in Cisco Guest portal. The web request works in SOAPUI 5.4.0 on my computer. The account is created successfully (pre-emptive authentication is needed to be used).

But in the workflow it returns The request was aborted: Could not create SSL/TLS secure channel error.

According to the documentation on above web site you need to use Basic authorization.

The web request action is set up as follows

It is basically the same way as in SOAPUI tool. I have tried the following none of which has helped:

  1. Add header Authorization: Basic UserNameSmiley Tongueassword as per the documentation in above link
  2. Removed the content-type header since it is already in Content type mandatory field of the action.
  3. Removed username and password from the action fields and kept it just in Authorization header

I have tried to open the request url directly in IE on WFE server and after entering the UserName and Password into the pop up window it authenticated me normally.

Any idea what am I missing here please?

Many thanx

Jan

Labels: (2)
Reply
1 Reply
marekan
Nintex Newbie

Re: Workflow Web Request returning The request was aborted: Could not create SSL/TLS secure channel.

Jump to solution

Hi all,

in case someone deals with the same problem.

We have solved this with Nintex support by following these steps (in our SharePoint 2013 environment with Nintex workflow 2013).

You need to have .NET 4.5 or higher installed on your WFE(s). If you have .NET 4.6 and above then you do not need to do anything and the action will work.

If you have 4.5 version then you need to create these entries in the registry on WFE(s).

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319]

"SchUseStrongCrypto"=dword:00000001

 

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework\v4.0.30319]

"SchUseStrongCrypto"=dword:00000001

Then restart the SP timer service and IIS and run the WF again.

All should work fine.

Jan

View solution in original post

Reply