cancel
Showing results for 
Search instead for 
Did you mean: 
vamshi_govindu
Nintex Newbie

Workflow Task - inserting hyperlink with reference to item property not working

I am trying to insert a hyperlink into the task description and task notification that has the display text as "Some random text: ListItem_FieldValue". When I use Insert link option on the ribbon and assign the following value in the Hyperlink text to display - Some random text: {ItemProperty:Name}, It shows up as "Some random text: Name" instead of "Some random text: Value_of_Name_Field"

Labels: (2)
Tags (2)
0 Kudos
Reply
3 Replies
Automation Master
Automation Master

Re: Workflow Task - inserting hyperlink with reference to item property not working

just to be sure, does it display name instead of value in notification after task is created or does it show so in designer?

would you mind to post code from 'Edit source' that is generated for you (try to make it as simple as possible)

Reply
Highlighted
vamshi_govindu
Nintex Newbie

Re: Workflow Task - inserting hyperlink with reference to item property not working

It shows up as name in the notification. I know the reason why it is not working,  the question is why is it happening and is there a way to make it consistently work?

The markup is 

Working code in send email notification action:

<span id="NWRTEReference1">

<a class="ms-rtestate-write" contenteditable="false" onclick="selectThis(this);" href="javascript:void(0);" reflink="{Common:ContextItemUrl}" reftext="Link%20%3A%20%7BItemProperty%3AName%7D" link="true" style="color: blue; text-decoration: underline;">Link : Title</a>

 

 

Not working code in the task action:

><span id="NWRTEReference5"><a class="ms-rtestate-write" contenteditable="false" onclick="selectThis(this);" href="javascript:void(0);" reftext="Approval%20request%3A%20Name" link="true" reflink="{Common:ApprovalUrl}" style="color: blue; text-decoration: underline;">Approval request: Name</a></span>

0 Kudos
Reply
Automation Master
Automation Master

Re: Workflow Task - inserting hyperlink with reference to item property not working

hm, is task action's markup just exact as you posted it?
including orphaned 'grater then' sign at the very beginning?

if so, I'd guess you manually edited the text and markup got broken.
I'd sugest to set it up once again from scratch.

0 Kudos
Reply