Problem with tie being an hour out on email

  • 14 September 2016
  • 0 replies
  • 2 views

Badge +6


 

Symptoms


Issue:
Problem with tie being an hour out on email.
The client has a form which allows the user to select a date and time. The time selected is saved correctly to the database however when I select the datetime field to be shown in the email functionality using the send email rule on smartforms, it is an hour out. Also it appears with a Z on the end(Zulu time).
 

Diagnoses



Diagnosis:
I was able to reproduce the issue on my environment my setting the region settings to Uk timeenglish UK and by also changing the the below:

On the following locations C:Program Files (x86)K2 blackpearlK2 smartforms Runtime and C:Program Files (x86)K2 blackpearlK2 smartforms Designer:

On the web.config file to "SmartObject.ExecutionCulture" value="en-GB" /andgt ?

This is a known issue and it was linked to an existing bug item(Bug: K2SF Runtime: Current Date and time incorrect displayed during runtime for an Item View - Zulu time is returned)
 

Resolution

Resolution:
This might be slated for a future release of K2.
 




 

0 replies

Be the first to reply!

Reply