cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

WebService Call returns no values when run as scheduled task

Hello guys,

i have a little problem with the workflow i created. It's kind of mysterious, maybe a permission problem... i'm not sure. The particular workflow runs properly when i start it manually, but when i let it start scheduled the included Web Service Call returns no values, which are needed for the following loop. It would be awesome if you could help me with this problem?! Thanks in advanced.

Labels: (2)
Reply
7 Replies
fhunth
Nintex Newbie

Re: WebService Call returns no values when run as scheduled task

Did you get any error from the action?

Reply
Not applicable

Re: WebService Call returns no values when run as scheduled task

Yes i get an error message... the message is too long for the history list so i have to send it to myself by mail when the workflow runs again. I will post it then.

Reply
Not applicable

Re: WebService Call returns no values when run as scheduled task

Ok it seems to be a problem with the proxy settings! I have to discuss this with my colleagues. If we can solve the problem I will write a more detailled description.

Reply
Not applicable

Re: WebService Call returns no values when run as scheduled task

Hi could you provide a screenshot of error message and of the configuration settings of the web service action?

0 Kudos
Reply
Not applicable

Re: WebService Call returns no values when run as scheduled task

Hi Chris Oeinck​,

Not related to the question you are asking, but why are you using the 2 commit pending changes actions (before and after the Web Service), The from what i can see in the screenshot, you are not changing any values on SharePoint. The commit pending changes (especially 2) action can have quite an impact on performance when you have a very big collection to loop through.

if you need one, put it above the "For Each: Project No.". The one below the web service does not seem required.

You might want to check if you require one here: Designing your Workflow - Commit Pending Changes Action NW2010 & NW2013

Reply
Not applicable

Re: WebService Call returns no values when run as scheduled task

I'm always a little afraid of errors because that processes are not finished so that

empty values are handed over or something similar. So thanks for the advice i will change that.

Reply
Not applicable

Re: WebService Call returns no values when run as scheduled task

Hey guys,

thanks to Fernando who pointed me to error analysis again. It were infact our proxy configs that were not wrong.

This post helped to solve the problem. Thanks for the replies guys.

Re: "Request failed with status: Proxy Access Denied" when trying to Call a web service.

0 Kudos
Reply