cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
glenda
Nintex Newbie

Web Service error


Guys,

 

I'm trying to add web service to create SharePoint groups in a certain site collection.

I am currently having two errors here. Could someone help out?

 

  1. I get this proxy error - does it mean our firewall is blocking my request or is it a permissions error? I have farm admin permissions and site collection permissions on the site collection I want to call the usergroups.asmx. If I am not mistaken the permissions should be OK (I would even only need Full Control permissions to perform the action?).

Call Web Service.png

2.  Normally seen my workflow should decide upon which site collection I want to do a web service, but I get the following. It does not recognize my URL.

web service URL.PNG

Thanks,

Glenda

Labels: (1)
0 Kudos
Reply
1 Reply
Automation Master
Automation Master

Re: Web Service error

Your ISA server is denying the request because of a content rule most likely. Most common rules require all responses to have a specified Content Type in the header of the request. One may not be specified but can be in the web service call. you can Check by clicking on the soap editor. But if the refresh button will not work at all with this error, you may have an issue with the rules in the ISA server and possibly need it to be adjusted for you.

But the second bullet is not really an issue. You can have references in the URL for your workflow. But, when you are setting up the web service action for the first time, use a manually set URL with no references, define the method call and other fields to complete the setup of the action. You can test it with the manual URL also. Then add the reference in the URL last for it to be dynamic at runtime.

0 Kudos
Reply