cancel
Showing results for 
Search instead for 
Did you mean: 
harryr
Nintex Newbie

Validation rules not working

Jump to solution

I am running the latest version o Nintex Forms on SharePoint 2013 Enterprise and can't get the validation rule on a form to work. It worked first time, but every attempt to test in the preview fails to use the validation. I am using IE11 for testing as that is the target browser for our users.

I have added a rule on a drop down control and told it to look at the values in two drop-down controls and see if they are equal.

the rule as I have written it is:

Control is invalid if:

Then show a message that says that the choice for Funding Type should be "A".

This worked once and the failed to function every time after.

I created another formatting rule to hide a panel based on a choice and that works fine.

Does anyone have any experience of what could prevent validation rules from working? This is driving me nuts as I am sure the rule is written correctly when it worked the first time. I have also tested it in Firefox with the same result.

Appreciate any help.

Labels: (2)
0 Kudos
Reply
15 Replies
Automation Master
Automation Master

Re: Validation rules not working

Jump to solution

what are BusinessUnit and FundingType, named controls or item properties?

0 Kudos
Reply
harryr
Nintex Newbie

Re: Validation rules not working

Jump to solution

They are drop-down named controls.I have applied the rule to drop-down control A but tested it on the 'Save' button and elsewhere and this simple operation just doesn't work.

0 Kudos
Reply
Automation Master
Automation Master

Re: Validation rules not working

Jump to solution

are they dropdowns for choice field or dropdowns for lookup field?

0 Kudos
Reply
harryr
Nintex Newbie

Re: Validation rules not working

Jump to solution

They are choice drop-downs not lookups from other lists.

0 Kudos
Reply
Automation Master
Automation Master

Re: Validation rules not working

Jump to solution

ok.

so to debug what's going on with the formula I'd suggest following

- place 3 calculated value controls on form

- configure fromula for 1st one just to: BusinessUnit

- configure fromula for 2nd one just to: FundingType

- configure fromula for 3rd one to: BusinessUnit=="A"&&FundingType=="B" (configure it anew, do not copy&paste)

post a screenshot how do they evaluate

0 Kudos
Reply
harryr
Nintex Newbie

Re: Validation rules not working

Jump to solution

II added those fields as per your instruction and then ran the form making the choices. The sum appears to result in "false". For context A is the BLC value and B is the Time and Material value. The third is the result of the sum.

The sum is:

BusinessUnit=="BLC"&&FundingType=="Time & Material"

Thanks

0 Kudos
Reply
Automation Master
Automation Master

Re: Validation rules not working

Jump to solution

hm, don't you have some orphaned space in some string?

can you add calculation with following formulas

length(BusinessUnit)

length(FundingType)

and just just to be sure, two another calculations with formulas

FundingType=="Time & Material"

BusinessUnit=="BLC"

0 Kudos
Reply
harryr
Nintex Newbie

Re: Validation rules not working

Jump to solution

Done. Here is the result (in order of your instructions). Very odd. Not sure what to make of this. i have checked every field on the rest of the form for any possible duplicates and not found any 

0 Kudos
Reply
harryr
Nintex Newbie

Re: Validation rules not working

Jump to solution

I used a variation of the formula in the calculated column to check when the values DoNotEqual:

The result is returned as True.

I used the same formula in the rule and but it still does not fire and present the error message i configured:

Not firing message when validating:

It's starting to look like the product feature (validation rules) is broken?

0 Kudos
Reply