cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Nintex Newbie

Using Nintex Form for a New List Item

I've created a Nintex form for a SharePoint 2019 list and published it.  However, when I click on +New to create a new list item, the panel opens on the right side of the list and the fields don't reflect the Nintex form.  

How do I get the SharePoint list to use the Nintex form?  Do I need to change something in the list's settings?

 

 

Labels: (1)
Tags (1)
0 Kudos
Reply
11 Replies
Highlighted
Nintex Newbie

Re: Using Nintex Form for a New List Item

How did you create the Nintex form? Did you go to List- Nintex Forms-Customize the Form to either Clasis or responsive?

0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Using Nintex Form for a New List Item

Yes, went to List, Nintex Forms, tried it the first time with Responsive, then tried using Classic.  I have the same result either way.

0 Kudos
Reply
Highlighted
Nintex Employee
Nintex Employee

Re: Using Nintex Form for a New List Item

Hi,
Can you provide a screen shot of the issue?
Sounds like you are using modern view, do you see the same issue in classic view?
0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Using Nintex Form for a New List Item

I have the same issue in modern and classic view.  Here's form I created followed by what opens in classic and modern views:

Nintex formNintex formClassic viewClassic viewModern viewModern view

The form that opens has fields I no longer need to complete and is missing new fields.

0 Kudos
Reply
Highlighted
Nintex Employee
Nintex Employee

Re: Using Nintex Form for a New List Item

The forms that are being displayed are default SharePoint forms.
You are able to create different forms for different content types. Are you sure you have published the for for the content type that is being used when you click new?
0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Using Nintex Form for a New List Item

This list only has one content type: Item.  I've tried changing the settings for "Allow management of content types?" from Yes to No, and have the same result either way.  Could the issue be that the Form Options is set to "Customize the current form using MIcrosoft Infopath"? 

Use Infopath.jpg

0 Kudos
Reply
Highlighted
Nintex Employee
Nintex Employee

Re: Using Nintex Form for a New List Item

No this is not the issue.
If you create a new list with just the default "item" content type and then create and publish a form does that work?
0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Using Nintex Form for a New List Item

Yes, the form works correctly for a new list.  

0 Kudos
Reply
Highlighted
Nintex Employee
Nintex Employee

Re: Using Nintex Form for a New List Item

Ok,
So there seem to be an issue with that particular list then.
0 Kudos
Reply