cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

Update Nintex Workflow 2013 Installer crash

Jump to solution

Hi,

I was trying to update Nintex Workflow 2013 from 3.0.8.0 to 3.1.7.0 this weekend, but the installer crashed everytime when trying to "Disabling Workflow Timer Job..."

Has anyone else experienced this problem?

Any help would be appreciated, thanks!

0 Kudos
Reply
11 Replies
Workflow Hero

Re: Update Nintex Workflow 2013 Installer crash

Jump to solution

I have not experienced this problem before during updates. Have you reviewed this documentation? Nintex Workflow 2013 - Product Update Process

Reply
Workflow Hero

Re: Update Nintex Workflow 2013 Installer crash

Jump to solution

Hi Andrew,

thanks for your reply. Yes I have reviewed this documentation.

It looks like there was a problem with the currently installed .NET Framework causing the installer to crash.

I will update our Sharepoint Servers in a few weeks and try it again.

I'll get back to you if the problem persists.

Thank you!

Reply
Workflow Hero

Re: Update Nintex Workflow 2013 Installer crash

Jump to solution

Hi Patrick. How did you go with fixing this issue? I am having the same problem trying to update to 3.1.7.10 but my .NET framework seems ok.

any hints would be greatly appreciated.

Thanks

UPDATE:

We have just updated to the January 2016 update on the SP servers so I'm wondering if this is causing an issue. Anyone else had success updating Nintex after this update?

UPDATE 2:

I tried deploying the 2 test solutions from Nintex and they both worked fine.

0 Kudos
Reply
Workflow Hero

Re: Update Nintex Workflow 2013 Installer crash

Jump to solution

I got the Nintex Workflow 3.1.7.10 to work. The application pool on our web front end server had stopped so I just restarted, retracted both Nintex Forms and Nintex Workflows and then ran the updates again.

Reply
Not applicable

Re: Update Nintex Workflow 2013 Installer crash

Jump to solution

Hi Robyn.

I'd assume you will have the same issue next time you upgrade too - we have had this problem across multiple versions of the installer.  Usually with a 0xc0000005 error in Clr.dll, which is a .Net framework file and the installer crashing at the same point as you saw.  Using the extract method and running the install.ps1 script works.

Thanks

Reply
Workflow Hero

Re: Update Nintex Workflow 2013 Installer crash

Jump to solution

Hi Patrick,
Have you tried to run the installer on different Server on your Farm?
Let us know if that will work.
What we have seen in the past, that some servers in the Farm the SPTimer service just take long time to restart, and that cause these issues.
Hope that help, Majid

Reply
Workflow Hero

Re: Update Nintex Workflow 2013 Installer crash

Jump to solution

Hi Patrick,

I ran into a similar issue a few upgrades ago.  Mine worked fine once I ran it the second time around. For my last upgrade I ran into an issue where IIS wasn't started but I could just manually start up IIS. So that bit was solved easily.

Did you run the installer with the run as Administrator option?

Reply
Workflow Hero

Re: Update Nintex Workflow 2013 Installer crash

Jump to solution

Hello Damian,

I have the same problem (coming from 3.0.8.0). SharePoint and Windows System is fully patched (this weekend).

Tried to install different workflow installers more then 8 times.

What do you mean with: "Using the extract method ..." ?

Where can I find "install.ps1" script? 

I am a littleb it desperated.

TestingSolutionGlobal as well as TestingSolutionForWebApps can not be deploedfrom central admin.

Franz

0 Kudos
Reply
Workflow Hero

Re: Update Nintex Workflow 2013 Installer crash

Jump to solution

H,

Found the answer for the How-To "exctract method" in "Automating the Install of Nintex Workflow" by Dan Stoll

http://www.sharepointpub.com/automating-the-install-of-nintex-workflow/

Extraction for manually PowerShell deployment is done at the second installscreen.

"install.ps1" is in "/workflows"

This was successfully :-)

After this the assisted (standard) installation was also successfully. Now I am on current state with this server.

As well as deployment of "TestingSolutionGlobal" and "TestingSolutionForWebApps"

Regards, Franz

Reply