cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

Unable to create workflow start form with Nintex Forms after update

Jump to solution

Hi,

we updated Nintex Workflow (3.1.6.0 to 3.1.7.10) and Nintex Forms (2.6.0.0 to 2.9.0.0) some days ago in our dev environment. During testing, we found that we're unable to create workflow start forms or open/edit previously created start forms with Nintex Forms.

Scenario:

  1. Create new or edit existing Nintex Workflow
  2. Go to Workflow Settings
  3. Choose Edit Start Form > Edit with Nintex Forms

The Nintex Forms Designer does not open. The "Please wait..." dialog is shown < 1 sec. and disappears without further information or error message.

It seems to have something to do with authentication. Within Verbose ULS, we can see the following entries after hitting "Edit with Nintex Forms":

  • SPApplicationAuthenticationModule: There is no Authorization header, can't try to perform application authentication.
  • Claims Windows Sign-In: Sending 401 for request [SPSiteURL]/_layouts/15/NintexWorkflow/_vti_bin/NintexWorkflow/Workflow.asmx' because the user is not authenticated and resource requires authentication.
  • SPFederationAuthenticationModule.IsRedirectToLogOnPage: This is a 302 redirect to /_login/default.aspx?ReturnUrl=%[URL]%2f_layouts%2f15%2fNintexWorkflow%2f_vti_bin%2fNintexWorkflow%2fWorkflow.asmx
  • SPFederationAuthenticationModule.IsRedirectToLogOnPage: Redirect to known signin page: /_login/default.aspx?ReturnUrl=%[URL]%2f_layouts%2f15%2fNintexWorkflow%2f_vti_bin%2fNintexWorkflow%2fWorkflow.asmx
  • SPFederationAuthenticationModule.OnEndRequest: User was being redirected to authenticate.
  • Claims Windows Sign-In: Sending 401 for request [SPSiteURL]/_layouts/15/NintexWorkflow/_vti_bin/NintexWorkflow/Workflow.asmx' because the user is not authenticated and resource requires authentication.
  • Server challenged request: 'The remote server returned an error: (401) Unauthorized.'

Workaround by hand:

  1. Deactivate "Nintex Forms for Nintex Workflow" feature on the problematic site collection
  2. Activate "Nintex Forms for Nintex Workflow" feature on the problematic site collection
  3. The editor comes up again

However, this does not work if we do this using PowerShell like:

  1. $Feature = "ac8addc7-7252-4136-8dcb-9887a277ae2c"
  2. Disable-SPFeature -Identity $Feature -Url $Site.Url
  3. Enable-SPFeature -Identity $Feature -Url $Site.Url

Can you help us with this?

Regards,

Tobi

Tags (4)
Reply
4 Replies
Workflow Hero

Re: Unable to create workflow start form with Nintex Forms after update

Jump to solution

Have you the chance to restart the server?

Reply
Workflow Hero

Re: Unable to create workflow start form with Nintex Forms after update

Jump to solution

Hi Tobi,

I had a bit of search,  apparently this is an issue which may happen when you activate a SharePoint feature using PowerShell while UI is working.  Some of the reasons are discussed here and here​. 

http://sharepoint.stackexchange.com/questions/35694/cant%C2%B4t-activate-a-custom-feature-with-power...

However, when you ran the PowerShell command did you have a chance to look at the log file if any particular error stands out? this might help us to get to bottom of the issue.

Reply
Workflow Hero

Re: Unable to create workflow start form with Nintex Forms after update

Jump to solution

Hi together,

we were unable to figure out what happened during setup or upgrade, a Nintex support case didn’t help either. However, setup on the production environment went well, and we ended in doing the manual workaround described above on all affected pages on our second environment.

0 Kudos
Reply
Not applicable

Re: Unable to create workflow start form with Nintex Forms after update

Jump to solution

I tried to use CSOM to activate this feature. And now, everything ok!

0 Kudos
Reply