cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
goodplans4us
Nintex Newbie

The validation formula I use for some fields is working but not for others, please help

I have a few fields that will be required for all submissions. I thought it was interesting that it didn't pick up the out of the box requirement from list settings. 3 of fields work with the following format: isNullOrEmpty(ProjectJobName) ; isNullOrEmpty(ProjectJobRequester) ; isNullOrEmpty(SecondaryContact). Three of the fields do not work with the same format - isNullOrEmpty(Department) ; isNullOrEmpty(Health Plan) ; isNullOrEmpty(Cost Center). Someone suggested I try [Self] instead of the name which I did for Health Plan and it worked. However, after looking more into it, it didn't work via Nintex, but, it enabled the list settings required field option to work. I know this because 1) I removed the rule and it still worked and 2) the message is different - mine is "Health Plan is a required field" and the out-of-the-box message is "This is a required field". We thought maybe it was because the field wasn't connected could be the issue but that's not the case with Dept and since Health Plan and Cost Center are in a panel that is a repeating section the can't be connected. Any ideas on how I can get Ninext to consistently accept the required fields from List Settings or make the above fields in question, work?

Labels: (1)
0 Kudos
Reply
1 Reply
Automation Master
Automation Master

Re: The validation formula I use for some fields is working but not for others, please help

have you checked developer console for any errors?

these are typical symptoms if there's an error in a rule or javascript.

0 Kudos
Reply