cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

The expression prefix 'NFResources' was not recognized. Please correct the prefix or register the prefix in the <expressionBuilders> section of configuration.

I'm currently receiving the following error when I attempt to access the customize Nintex forms option, "The expression prefix 'NFResources' was not recognized.  Please correct the prefix or register the prefix in the <expressionBuilders> section of configuration." I had my SharePoint Admin follow the instructions in https://community.nintex.com/community/support/blog/2015/01/16/error-the-expression-prefix-nfresourc... but that didn't resolve it.

Labels: (3)
Tags (1)
0 Kudos
Reply
10 Replies
Workflow Hero

Re: The expression prefix 'NFResources' was not recognized. Please correct the prefix or register the prefix in the <expressionBuilders> section of configuration.

Was the feature already activated so they made no changes? Or was it not activated for the web application and activating showed no changes?

0 Kudos
Accept as Solution Reply
Not applicable

Re: The expression prefix 'NFResources' was not recognized. Please correct the prefix or register the prefix in the <expressionBuilders> section of configuration.

Update: This appears to have been a mapping issue. I was given a link which goes to the same area but has a slightly different URL. When I use this link the forms editor works just fine. The reason this is occurring is not currently known but is being researched.

Thanks Andrew, but, yes, it was activated.

Accept as Solution Reply
Workflow Hero

Re: The expression prefix 'NFResources' was not recognized. Please correct the prefix or register the prefix in the <expressionBuilders> section of configuration.

Could you share this path variation? I am encountering the same issue

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: The expression prefix 'NFResources' was not recognized. Please correct the prefix or register the prefix in the <expressionBuilders> section of configuration.

I know you may have found your reason, but wanted to point out that Tech Support had posted about this error in the past just for reference if nothing else: Error: "The Expression prefix 'NFResources' was not recognized."

Accept as Solution Reply
Not applicable

Re: The expression prefix 'NFResources' was not recognized. Please correct the prefix or register the prefix in the <expressionBuilders> section of configuration.

Did anyone manage to get a solution to this issue as I am having similar problems where the feature has been activated on web app and on site collection but still get the NFResources error. 

can someone please advise?

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: The expression prefix 'NFResources' was not recognized.  Please correct the prefix or register the prefix in the <expressionBuilders> section of configuration.

You can reactivate the feature and see if that makes changes. Otherwise you may want to contact support for this type of error.

Accept as Solution Reply
Workflow Hero

Re: The expression prefix 'NFResources' was not recognized. Please correct the prefix or register the prefix in the <expressionBuilders> section of configuration.

We are having the same issue while opening nintex forms.It is activated on Webapplication

The expression prefix 'NFResources' was not recognized.  Please correct the prefix or register the prefix in the <expressionBuilders> section of configuration.

Any other solutions?

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: The expression prefix 'NFResources' was not recognized. Please correct the prefix or register the prefix in the <expressionBuilders> section of configuration.

I've recently had the same error.  For some reason, when activating the Forms feature on Web Application, it did not add the required entries to the web.config file!  In addition, the workflow web.config files were also not in the web.config file.  In fact, there were no Nintex references anywhere in the web.config file!

So I fixed my issue by adding the web.config entries manually as per this post:

 

Ran IISRESET

And then re-activated the Forms feature on the Web Application.

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: The expression prefix 'NFResources' was not recognized.  Please correct the prefix or register the prefix in the <expressionBuilders> section of configuration.

Good find! This tends to happen when there is a permission issue on the user installing the solution.

0 Kudos
Accept as Solution Reply