Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

Task Form not working with "Request Data"-action

Hi Community,

I have been fighting with this for few days now. I have created a workflow that request values from the user via the "Request Data"-action and after updates these to a list. The workflow works just fine but I am having trouble with the task forms. I am not sure how much of this is due to sharepoint and how much to nintex.

So when opening the task from the email generated by nintex (or unter my workflow tasks) it looks like this: 

I have found some mentions about directing the task directly to the edit mode but have not yet been able to implement it. Nevertheless, the users can manage to click "Edit Item". The problem is on the edit item view that looks like this:

This would be ideal,  but the "Complete Task" button is not doing anything. Clicking it will not give any feedback nor complete the task. I have tried to create a Infopath form to replace the oob form from Sharepoint but when publishing it the same edit view comes up after clicking edit. I have found a one time workaround but I have to do this each time a new task is generated. After publishing the infopath form, I can use the Tasklist settings to revert back to the Sharepoint Standard. This gives me the original OOB edit view: 

As mentioned on the next instance of the workflow the form reverts back to the one in the second picture.

I have tried creating a new workflow (with new task list) and content types with no success. Any help would be appreciated highly! I have a farm page where the forms work just fine. On the published page I am having such problems that are slowly destroying my mental sanity. 



Edit. I unfortunately do not have access to Nintex Forms...

Edit2. What I have been able to figure out today is that the problem seems to be related to the "Edit Form" view. The url for editing it on the standard view is Site-URL/TaskList/editform.aspx?ID=1 but when I change the Content Type to the one used in the workflow I get Site-URL/Tasklist/SNr_BTE_IST/SNr_BTE_IST.aspx?=List***a long unique id etc*** Sadly, I still have no clue how to fix this.

0 Kudos