cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

State Machine stuck when I make loop more than once

Hi,

I have an issue with my state machine

I just have a problem with my second branch (7 branchs in all)

Indeed, my state machine was stuck when it try to "change state".

In that second branch, I have a loop that passed through a collection of manager.

I send an email everytime. When the loop has been finished, I log into history a comment "End foreach".

Just after the log, I "change state" to my third branch.

The problem is :

When I have only one loop (so one email sent), it work well and the workflow passed to the third branch.

When I have more than one loop, the workflow was stuck in "In progress" status, no error in the workflow history and the last action is "Change state to third branch".

Further informations :

The workflow work when it passed between the first and the second branch.

I have already remove & re-create the branch.

The loop is work well in the branch and in another place in the workflow

Do you have an idea ? Because I don't where the problem is. Hope, you can solve it.

BR

Théo

Labels: (1)
0 Kudos
Reply
4 Replies
Workflow Hero

Re: State Machine stuck when I make loop more than once

Hi Théo,

what do you mean with your workflow gets stuck? Does it just wait forever or does it fail at some time?

Usually problems with looping have their roots in SharePoint Timer Service so restarting that Service on all your web frontends might be a good first try.

Also are there any logs in the ULS log?

Do you face the same problem on different sites or web application or do you even have a test environment to try it out too?

You could also go to Central Administration and open Nintex Workflow Management -> General Settings and check the safe looping property. If it's set to "Yes" you could test the workflow with disabled Safe Looping and see how it performs. If you disable safe looping loops will cause some more load at once to your web frontends but for a short time you can easily disable it. Keep in mind that you need to restart IIS and republish your workflow after changing safe looping activation.

Kind regards,

Enrico

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: State Machine stuck when I make loop more than once

could you try following?

- add one another brand new branch. name it differently to any existing state or to any state name you might have used before within this workflow

- configure logic from your 2nd branch anew into this new branch. make sure you do not copy&paste any action but rather add it and configure from scratch

- reconfigure other branches so that this new branch is used instead of 2nd one

- do not do any changes to 2nd branch, let it be untouched there so far.

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: State Machine stuck when I make loop more than once

Hi,

First, thanks for fast reply.

‌ Yes, the workflow wait forever when he try to switch between branch 2 and branch 3. I will see with network people if they can reset IIS.

‌ I try it and I get back to you with my feedback.

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: State Machine stuck when I make loop more than once

This does sound like a Timer Service issue.   Were you able to reset it and confirm?

Accept as Solution Reply