cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

Starting a workflow with Call Web Service timing out

Jump to solution

We have a parent list workflow (let's call it P1) that starts a child site workflow (C2) using the Nintex Call Web Service action.  The Call Web Service action uses Workflow.asmx, Web method StartSiteWorkflow. We are using the web method to start the workflow in order to pass associationData. 

P1 starts C2, as expected. However, after 1-2 minutes, P1 fails with error “Failed to invoke web service. Error returned from server: The operation has timed out”.

Despite the error message, C2 continues to execute and completes successfully.

This seems like it must be a configuration related specifically to Web Services, as we do not have this issue when starting the workflow using the Nintex Start Workflow action.

Has anyone seen this behavior before?  Do you have any suggestions on what might be happening, or how to correct? 

We have recently converted to SharePoint 2013.  This was not an issue in SharePoint 2010.

Thank you for any input you might have!

0 Kudos
Reply
9 Replies
Workflow Hero

Re: Starting a workflow with Call Web Service timing out

Jump to solution

is it only reason to pass data into child workflow so that you use web service?

if so, then you still can use Start Workflow action, but you need to declare variables in child workflow as 'Show on start form'

Reply
Workflow Hero

Re: Starting a workflow with Call Web Service timing out

Jump to solution

Thanks Marian, I did not know you could do this!  I thought you had to use Call Web Service to start the workflow if you wanted to pass data.  I will definitely give it a try!

Reply
Workflow Hero

Re: Starting a workflow with Call Web Service timing out

Jump to solution

Hi Marian,

The variables that I want to pass to the child workflow are defined and populated in the parent workflow.  I am using the "Start Workflow" action. 

In the child workflow, the variables are defined and 'Show on start form' is checked.  Required is not checked - should it be?  When I run the parent workflow, none of the variables is populated in the child.  What am I missing?

Thanks!

0 Kudos
Reply
Workflow Hero

Re: Starting a workflow with Call Web Service timing out

Jump to solution

have you reconfigured start workflow action in parent workflow?

there should appear new input parameters once you changed child workflow.

if so, try so write parameters handed over to history log, both in parent workflow and child workflow, to make sure they are really populated the way you expect.

if that still doesn't help, post how does you configuration looks like, and provide info what are data types of passed parameters.

Reply
Workflow Hero

Re: Starting a workflow with Call Web Service timing out

Jump to solution

Worked like a champ once the "Start Data" fields showed up on the "Start Workflow" action.  They weren't there the first time I configured it.

Thanks again Marian, you're the best!

0 Kudos
Reply
Workflow Hero

Re: Starting a workflow with Call Web Service timing out

Jump to solution

not yet, but maybe once

0 Kudos
Reply
Workflow Hero

Re: Starting a workflow with Call Web Service timing out

Jump to solution

And how is this trick done in O365?!

Cheers

mai-kel

0 Kudos
Reply
Workflow Hero

Re: Starting a workflow with Call Web Service timing out

Jump to solution

I'm sorry, I do not know. I've no experience with O365.

0 Kudos
Reply
Workflow Hero

Re: Starting a workflow with Call Web Service timing out

Jump to solution

You??? Really?

Bildergebnis für dafuq

0 Kudos
Reply