cancel
Showing results for 
Search instead for 
Did you mean: 
dgoodridge
Nintex Newbie

StartWorkflowOnListItem 404 The requested resource is not found

I'm having an issue that's driving me nuts. I have used StartWorkflowOnListItem I don't know how many times, but for some reason I can't get it to work in this instance. 

I have a scheduled site workflow that queries a list for items who's date column equals today. The resulting IDs are stored in a collection. Then I run a For Each loop on the collection, storing the item ID in a number variable. The Call Web Service action is configured for NintexWorkflow/Workflow.asmx - StartWorkflowOnListItem. I pass the item ID from collection (I've checked the variable and it's coming across as a number), the list name, Workflow name, and no association data. 

When I "Run Now" it works fine. When the action is triggered during the scheduled site workflow I get error text "HTTP Error 404. The requested resource is not found." I have tried configuring the action with a hard-coded item ID value, but same results. I even tried recreating the list and site workflow to no avail. I am site collection administrator, as well as having rights over the web application. 

Can someone please explain what is going on?!?!?!

0 Kudos
Reply
5 Replies
Automation Master
Automation Master

Re: StartWorkflowOnListItem 404 The requested resource is not found

do you run it scheduled with the same credentials as testing with run now?

do you correctly provide site reference for a web service endpoint?

could you post your action configuration?

0 Kudos
Reply
dgoodridge
Nintex Newbie

Re: StartWorkflowOnListItem 404 The requested resource is not found

The WF was created and published by my account, which has admin rights across the web application. I have properly configured the URL and method, and the account running the method is Farm Service Account. In the example below, I have hardcoded the Item ID to run on (for testing). Again, this Call Web Service action will execute properly when I Run Now, but not when the Scheduled Site WF executes it. 

0 Kudos
Reply
Highlighted
Automation Master
Automation Master

Re: StartWorkflowOnListItem 404 The requested resource is not found

have you tried to run the workflow manually from workflow inventory?

have it worked?

0 Kudos
Reply
dgoodridge
Nintex Newbie

Re: StartWorkflowOnListItem 404 The requested resource is not found

Yes, it works properly if I go to the action and Run Now, or if I start the site workflow manually. It only errors when the WF runs as a scheduled WF. 

Is there a workaround to get a scheduled site workflow to start a workflow on a list item? 

0 Kudos
Reply
Automation Master
Automation Master

Re: StartWorkflowOnListItem 404 The requested resource is not found

hm, it looks like scheduler timer job cannot reach web service URL provided for any reason.

do you reference site within the same farm or is it from different farm?

could you try to logon locally with respective service account which scheduler timer job runs with and test with run now?

could you simply try to query list item from scheduled workflow instead of starting a workflow on it?

could you try to use list GUID in place its name?

Is there a workaround to get a scheduled site workflow to start a workflow on a list item? 

only if you update the item from site workflow and let the list workflow run on update

0 Kudos
Reply