cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Nintex Newbie

Send Email Action delay after the email is sent and received

Jump to solution

Hello!

 

I have a strange issue. I had noticed some slow downs in the speed of worklfows on my farm. I thought it was just the audit table getting too big but after maintenance, I have narrowed the slowdown to the Send Email Action.

 

What is happening is as follows. The Worklfow runs quickly until after a send Email action, where there seems to be a pause of 15 to 30 seconds before the workflow continues or ends if that is the last action. I.E. If I have a workflow which sends two emails, the first is recieved promptly there is then a delay until the 2nd one hits and then the workflow continues for another 15 - 30 seconds even though it has nothing to do.

 

You can see from by pic below that each send email action is taking longer than normal. EmailSlow.JPG

Any idea's?

 

Thanks T.

Labels: (1)
0 Kudos
Reply
1 Reply
Highlighted
Nintex Newbie

Re: Send Email Action delay after the email is sent and received

Jump to solution

Finally solved it. It was spam protection from exchange. For what ever reason my Sharepoint emails were being detected as spam.

Tarpit and MaxAcknowledgementDelay parameters on the receive connectors was the issue. These were set to 30 seconds.  

 

Set-ReceiveConnector -Identity "EXMBX107\APP - Sharepoint - EXMBX107" -TarpitInterval 00:00:00
Set-ReceiveConnector -Identity "EXMBX107\APP - Sharepoint - EXMBX107" -MaxAcknowledgementDelay 00:00:00

View solution in original post

Reply