cancel
Showing results for 
Search instead for 
Did you mean: 
omar_taha
Nintex Newbie

Scroll is not working when multi line text input is disabled in ie

Jump to solution

Hello,

I recently noticed an issue, that when I disable multi line text and it's view mode is edit, the scroll also disabled and cannot view the rest of the text on ie browser, but it is working on chrome, is this a bug?? and how to solve it.

Nintex-Bug.PNG

Thanks

Tags (1)
Reply
4 Replies
Automation Master
Automation Master

Re: Scroll is not working when multi line text input is disabled in ie

Jump to solution

Hello Omar Taha​,

I built a quick demo to reproduce the issue you're seeing and it looks your issue results from the differences between the disabled and read-only attribute:

Difference between disabled and read only attributes

I did some digging into the multi-line text control properties and although I was unable to find an entirely out of the box solution, the following custom JQuery will provide the read only behavior you're needing.

NWF$(document).ready(function() {

  NWF$('#' + test).attr('readonly','readonly');

});

This assumes that your multi-line text control has a JavaScript Client ID variable of 'test'. Good luck!

Reply
omar_taha
Nintex Newbie

Re: Scroll is not working when multi line text input is disabled in ie

Jump to solution

Thanks Patrick, but why it is working on chrome, but not on ie, is it bug in nintex, or the problem is in ie??

0 Kudos
Reply
omar_taha
Nintex Newbie

Re: Scroll is not working when multi line text input is disabled in ie

Jump to solution

I tried to use your script, but readonly does not work for me, I used instead of it this script

NWF$("#" +readonly_textarea").attr("contentEditable","false");

where readonly_textarea is the stored id of the multi line text.

Thanks for helping me.

Reply
Automation Master
Automation Master

Re: Scroll is not working when multi line text input is disabled in ie

Jump to solution

sure no problem!

I was actually only testing in Chrome (wasn't aware IE might treat the read-only attribute differently). I'm glad this got you going in the right direction though, good luck!

0 Kudos
Reply