cancel
Showing results for 
Search instead for 
Did you mean: 
nirmala
Nintex Newbie

Scheduling a site workflow ends unexpectedly with "Failed to start" error

I’ve a site workflow with just one action (Email notification). The workflow works perfectly fine if I start it manually, but adding a schedule to execute the same workflow is not working. In the first instance i receive an email saying that the workflow failed to start and immediately i receive the actual email as a response to successful execution of the workflow.

  

I have checked the workflow schedule, the 'Last Run' value still says 'Not Run' and the 'Next Run' value hasn't been changed at all.

I have checked the "Nintex Workflow Scheduler" Timer job and have used NWAdmin to enable it to run against the web application. I have cross checked whether if i have more than one "Nintex Workflow Scheduler" jobs, but no i only have one.

I have run out of all options.

Very much appreciate any help with this?

Thanks,

Nirmala

0 Kudos
Reply
5 Replies
michael_creek
Nintex Newbie

Re: Scheduling a site workflow ends unexpectedly with "Failed to start" error

...try adding a delay (5 minutes) to the workflow.

0 Kudos
Reply
Highlighted
nirmala
Nintex Newbie

Re: Scheduling a site workflow ends unexpectedly with "Failed to start" error

Hi m c

Thanks for your reply. I have tried adding a delayof (5 min), and still receiving a "Workflow Errored" email saying, "workflow failed to start" as follows. 

The only change now is, i am not receiving another email of successfull completion of the site workflow. So, no duplication of the workflow, but still no proper execution of the workflow.

Thanks,

Nirmala

0 Kudos
Reply
michael_creek
Nintex Newbie

Re: Scheduling a site workflow ends unexpectedly with "Failed to start" error

Here’s the solution Nintex recommends…have not used it, so cannot verify.

Nintex Solution<https://support.nintex.com/SharePoint/Workflow/Error_%22Failed_on_start_(retrying)%22>

0 Kudos
Reply
nirmala
Nintex Newbie

Re: Scheduling a site workflow ends unexpectedly with "Failed to start" error

Thanks for the link m c, as the link prompted me to check the other info and came across the "Microsoft SharePoint Foundation Workflow Timer Service". As this service needs to be running only on to the WFE server, but in my case it was running on both APP and WFE. Stopping the service on APP server has fixed the issue.

Thank you,
Nirmala

0 Kudos
Reply
Nintex Employee
Nintex Employee

Re: Scheduling a site workflow ends unexpectedly with "Failed to start" error

Hi Nirmala,

Removing the Workflow Timer Service from app servers will work, as will running the script below from one of your Web Front Ends.  The script below will make the Workflow Configuration settings available within the SharePoint Configuration database for access by that web application.  Without running the script, only servers configured with the Web Application Service will have those settings readily available.

$webapp = Get-SPWebApplication -identity http://<web app name> 
$webapp.UpdateWorkflowConfigurationSettings()
0 Kudos
Reply