Getting LDAP Error

  • 12 November 2015
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Symptoms

 


K2 Workspace is suddenly failing with error:

An error has occurred.
Please contact your administrator.
Error:
Initialization failed before PreInit: Unable to establish a secure connection with the Active Directory server.
Possible causes
- the ADConnectionString in the K2 Workspace web.config may have an incorrect LDAP path.
- the physical connection to the Active Directory Server might be down.
- please review log files for more information.
 

 

Diagnoses

 


As K2 Workspace was working and suddenly failed, it is likely that connectivity was lost to one of the domain controller returned by the LDAP paths in this multi-domains configured K2 environment. One way to perhaps test which domain controller/LDAP it may be, is to use the following query to retrieve the domain controller machines (usually the PDC will be used):

nltest /dclist:denallix.com

Then perhaps using 'ping' or 'telnet [machinename]:[389-defaultLDAPport]' to determine connectivity and verify with the AD team.

Once verified, you an perhaps try changing the ADConnectionString to the following format (targeting a good domain controller):

LDAP://[DomainControllerServerName]:389/DC=DOMAIN,DC=COM
 

 

Resolution

Determined that one of the domain controllers for a specified LDAP path was temporarily down as such this LDAP path was removed from the multi-domain configuration as well as commented out in the web.config file for K2 Workspace.

Once this domain controller is online again, it can be re-added to the multi-domain configuration/uncommented in the web.config. When configuring multi-domain via K2 Workspace > Management > Server:Port > User Manager > K2 > Domains a K2 blackpearl service restart is necessary afterwards.

 

 



 

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