cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

Rules not working in display mode

Requirement: Hide the attachments control from New/Edit/Display for specific users.

1) Created a panel and placed the attachments control.
2) Added formatting rule to the panel using contains and current user condition

Issue: rule is working on EDIT & NEW modes but it’s not working on display mode. I can’t get “current user” value in display mode.

I'm using Nintex Forms 2010.

Please help

Tags (1)
Reply
3 Replies
Workflow Hero

Re: Rules not working in display mode

could you post how does your rule exactly look like?

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Rules not working in display mode

Thanks for the reply Maria. Here is my formula for the rule:


not(contains(lookup("Invoice Approval Tasks","Title",TaskTitle,"Assigned To"),userProfileLookup(Current User,'PreferredName')))&&not(fn-isMemberOfGroup(ProcurementTeam))

If the above rule return true the attachment panel should be hidden. Rule is working on New/Edit mode as expected but it's not working in display mode.

For troubleshooting purpose i have added a "calculate value" field to the form and included "Current User" from Common. But i can't see current user name in display mode. hope this helps you

Please let me know if you have any questions.

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Rules not working in display mode

For troubleshooting purpose i have added a "calculate value" field to the form and included "Current User" from Common. But i can't see current user name in display mode.

have you enabled 'Recalculate formula in view mode' option for the control?

I'd recommend to add similarly calculated value controls for other formula subexpressions to identify which one doesn't evaluate as expected.

what is TaskTitle within lookup() call? does it evaluate properly in view mode?

can you as well check developer console whether there are not any errors reported?

0 Kudos
Accept as Solution Reply