cancel
Showing results for 
Search instead for 
Did you mean: 
lgiambar
Nintex Newbie

Redirect not working

Can someone please help me troubleshoot this?

I have been fighting with trying to get this form to redirect for far too long now and I can not get it to work. I have tried to use the redirect after submit in the web part, that did not work. I have tried to use custom JavaScript and a function in the client click on the button and that is not working. I have tried putting the redirect URL directly on the button in client click and that is not working. I have also tried to use the redirect within the form settings itself and that is not working. Any thoughts as to what my issue is??

Thanks!!

Reply
25 Replies
Automation Master
Automation Master

Re: Redirect not working

forms settings' redirect URl should definitely work...

what does 'not working' exactly means? do you get an error? does it redirect back to list? does the form submits (create an item) at all?

0 Kudos
Reply
lgiambar
Nintex Newbie

Re: Redirect not working

I have my form being filled out with a nintex form web part. The item gets submitted to the list correctly, but then rather than redirecting to the URL I want it to redirect to, it always just goes back to the home page of the site. 

0 Kudos
Reply
Automation Master
Automation Master

Re: Redirect not working

it should work either.

can you check whether you do not have configured (orphaned) redirect in form settings or submit button settings?

or maybe export and save your existing form and try to generate brand new default form and test with it?

0 Kudos
Reply
lgiambar
Nintex Newbie

Re: Redirect not working

What do you mean by "have not configured redirect in for settings"?

0 Kudos
Reply
lgiambar
Nintex Newbie

Re: Redirect not working

I exported and deleted my form and tested with the default form, it still does not redirect. I also upgraded my forms to the newest version so now I have the redirect on the button option and that doesn't redirect either. Ugh!

0 Kudos
Reply
Automation Master
Automation Master

Re: Redirect not working

see you 2nd screenshot from original post.

in form settings >> advanced there is a 'Redirect URL' field.

0 Kudos
Reply
Automation Master
Automation Master

Re: Redirect not working

is the page you redirect to working, resp. accessible to the user who submits an item?

can you maybe try with some publicly available page like google, microsoft...

can you try to redirect to an URL within the same site?

0 Kudos
Reply
lgiambar
Nintex Newbie

Re: Redirect not working

The redirect I am trying to get to work is a page within the same site. I tried google and it still did not redirect. I tried opening my form from the list by clicking new item and after I clicked "save", the buttons on the toolbar grayed out and the form went away but the page did not change. I have redirects working on other sites so I can not figure out what is wrong here. 

0 Kudos
Reply
Automation Master
Automation Master

Re: Redirect not working

is it a page stored in SitePages library?

then you could try to reference just its name without URL path, eg

0 Kudos
Reply