cancel
Showing results for 
Search instead for 
Did you mean: 
michaelpe
Nintex Newbie

Question about Parsing XML Data

Jump to solution

I'm trying to parse data out of a repeating section but when I store it into a collection, the collection is blank.

1) The Mass Update columns are stored in a variable (inputXML)

2) I use the Query XML {WorkflowVariable:inputXML} and use the XPath output (/RepeaterData/Items/Item) to store as a Collection variable called Collection Item

-   At this point, I can save this variable to a list item and see the content, so good so far.

3) I have a for each that takes the Target collection (Collection Item) and stores it into a Multiline Variable (MLOT_Item)

-   Here is where it breaks. One of the fields in the repeating section is AssociateName. AssociateName shows up under the variable inputXML, but once the Collection Variable is collected and stores the Items into the MLOT, it's blank.

I'm so confused why the collection variable wouldn't store the data? Anyway come across this issue?

Labels: (1)
0 Kudos
Reply
5 Replies
Automation Master
Automation Master

Re: Question about Parsing XML Data

Jump to solution

could you post screen shot of your workflow and setup of for each action?

example of your repeater data might help as well

One of the fields in the repeating section is AssociateName. AssociateName shows up under the variable inputXML

what you mean with that?

but once the Collection Variable is collected and stores the Items into the MLOT, it's blank.

what exactly is blank?

MLOT variable? collection variable? AssociateName element?

Reply
pfudala
Nintex Newbie

Re: Question about Parsing XML Data

Jump to solution

Hi Michael,

Did you use the "Outer XML" output to set your collection?

Try this and then, use another "Query XML" on each collection item with the XPath "/Item/YourData" to get data into your variable.

0 Kudos
Reply
kelliganp
Nintex Newbie

Re: Question about Parsing XML Data

Jump to solution

I agree with ‌. Screenshots of the workflow and actions configurations would be helpful. Also, just a hunch, look at your data types It could be an issue here. Is associate name a Person/Group data type? Could it be dropping at some point in the process due to a mis-typing? Lets see some screen shots... and a screenshot of the variable window would be good as well so we know what data types the variables are.

Reply
michaelpe
Nintex Newbie

Re: Question about Parsing XML Data

Jump to solution

Hey everyone, I figured out the issue. On the Query List option, the filter auto sets itself to run on all items in the list. We put a filter on this to have the ID equal the ID of the item. Kinda weird the default is to run on all items in the list so definitely something to check if you are running into this issue. Everything else was set correctly.

I can completely outline my issue in this thread if you all believe it may help others.

Reply
Automation Master
Automation Master

Re: Question about Parsing XML Data

Jump to solution

great you found a solution.

you haven't mentioned anything about query list, so it was hard to guess

however, what do you need query list for? all the fields of item the workflow is running on are exposed as item properties in workflow. you should have there listed your RS field as well. so no need for extra list query.

as well, I would say regardless of whether you filtered query list or not it shouldn't break query XML and for each loop functionality, if these are correctly setup. I would say you were just returned another item then you expected and hence empty values.

0 Kudos
Reply