cancel
Showing results for 
Search instead for 
Did you mean: 
burnsmh
Nintex Newbie

Print as PDF only using 1/3 page

I am having a problem with the Print as PDF function.

This is basically what the output of clicking it is.

My settings are:

I am using the responsive forms on Nintex with Sharepoint.

Anyone else having this problem?

As a work-around I've coded a RTF widget with a "Print Page" feature that I added a bunch of style tags to so that I can modify what gets sent out, but the issue is with IE/FF that those browsers are not accepting the code and the end user has to modify the browser settings to print them correctly or save them as a .PDF file.

0 Kudos
Reply
3 Replies
chaddavis
Nintex Newbie

Re: Print as PDF only using 1/3 page

I can tell you that we had major issues with how our PDFs were rendering because our master page's alternate CSS file had some issues. However, this was on classic forms so, idk if that will help.

0 Kudos
Reply
burnsmh
Nintex Newbie

Re: Print as PDF only using 1/3 page

I wish I had access to the HTML/CSS but with the responsive forms I do not. :c

I did, however, fail to mention. I turned off "Scale to fit" and tried it on "Landscape" instead of "Portrait" also I have tired it on "Legal" and "Letter". 

I am kind of at a loss as to why it looks like that.

0 Kudos
Reply
chaddavis
Nintex Newbie

Re: Print as PDF only using 1/3 page

Actually, our issue wasn't in the CSS of the form. It was under Site Settings -> (Look and Feel) Master Page -> Alternate CSS Url.

The CSS file we were using had many issues. For some reason, none of these issues affected how the site was displayed so it was never corrected, but they caused major issues with the Print to PDF in Nintex. I fixed the CSS code and the Print to PDF started working. I'll also add, the issues in the CSS file had nothing to do with '@media print'. There was just invalid code in the CSS, which apparently broke the Print to PDF.

I have no idea if this is the cause of your issues too, but I wanted to mention it because it took me forever to track down my issue.

0 Kudos
Reply