cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

No "Workflow Inventory" option in Central Admin

Jump to solution

All,

we have 3 SharePoint 2010 farms running Nintex Workflow 2.5.4.0 (Enterprise) - DB version 2.0.8.0.

On all 3 of them, I cannot find the "Workflow Inventory" option in Central Administration.

The page is there because I can enter the URL manually, and it works. But the option is not there in Central Administration.

I compared this to another SharePoint 2010 environment which has Nintex Workflow 2.4.7.10 (Enterprise) and that environment has the Workflow Inventory and also 2 extra options which I also don't have :

- Manage workflow reports

- Administration reports

Anyone any idea why this is happening and how to get them?

Labels: (1)
Reply
3 Replies
Workflow Hero

Re: No "Workflow Inventory" option in Central Admin

Jump to solution

All, some more information... I was going through the source of the _admin/NintexWorkflow/Management.aspx page and I noticed that those 3 missing options are there, but they are hidden using a "display: none".

I found the following in the markup:

 <%if(! IsEnterpriseEdition) { %>
adminReports.parentElement.style.display = 'none'; //hide the <li> element
var workflowInventory = document.getElementById(nwSettingsLinkPanelId + '_RptControls_NWWorkflowInventory');
workflowInventory.parentElement.style.display = 'none'; //hide the <li> element

var manageReports = document.getElementById(nwSettingsLinkPanelId + '_RptControls_NWManageReports');
manageReports.parentElement.style.display = 'none'; //hide the <li> element
<% } %>

And the IsEnterpriseEdition is set to True when the local server is unlicensed.

So, I'm guessing that my environments are not correct licensed.

We currently have 6 servers in our farm (3 WFE's and 3 APP's). Only the first 2 WFE's are used as actual WFE's and are loadbalanced. The 3rd WFE is used for exclusively for Search. So, the Workflow Timer Service is only running on the first 2 WFE's.

Central Administration is running on the 3rd APP server.

And this is my problem I guess... I only have licensed the first 2 WFE's. So the local server in Central Admin is indeed unlicensed.

 

What does need to be licensed in this case? Because the whole licensing thing is so damn confusing... some people tell you to license only the WFE's that server user requests, other people tell you that every WFE needs to be licensed... some other tell you that only those servers running the Workflow timer service needs to be licensed.

0 Kudos
Reply
Workflow Hero

Re: No "Workflow Inventory" option in Central Admin

Jump to solution

Hi Bart,

For Nintex Workflow 2010, there will be two types of servers that can / will be added to the license.

  1. Web Front Ends: servers running the Microsoft Foundation Web Application Service
  2. Application Servers: servers not running the Web Application service but can be running the Workflow Timer Service or Central Admin service.

You will only be charged for WFE's, but you will need to make sure that the App servers are also added to the license as App servers.

For SharePoint 2013 / 2016, there was a change in how licensing is applied to the farm, and you only need to have your WFE's on the license.  App servers will not need to be added in the license on these versions of SharePoint.

If you need to add additional servers to your license, you can reach out to your account manager, or licensing@nintex.com.  Hope this helps to clarify things a bit for you!

Reply
Workflow Hero

Re: No "Workflow Inventory" option in Central Admin

Jump to solution

Thank you for the clarification Dan.

This was indeed the problem. Only our WFE's were in the license. Not the server where Central Administration was running. Once we had this solved, the 2 options appeared.

0 Kudos
Reply