cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
arobins
Nintex Newbie

Nintex form does not recalculate calculated fields on form edit

Jump to solution

Hi all,

I'm creating a travel expense claim form which captures an employees total miles and parking in a pay period. This is done using calculated fields. This function works as intended.

 

There will be times when the form owner will have to edit it after it has been saved. In my testing, when I edit the form, all of the calculations resolve to zero's. The fields will only recalculate when I place my cursor in the form field and click out of it.

 

What I'm trying to do is have the form show the calculated totals when the form is edited or at the very least recalculate the totals when any form field is edited. I've ensured I'm using named controls in my calculated fields (Eric Harris‌). I did find a possible solution on a post by ‌ using javascript but the example uses the date difference and I can't seem to replicate the javascript to work with my problem - likey because my javascript skills are as good as my Nintex skills.

 

I've done a quick video to show what I'm talking about.

 

Any help is appreciated.

Labels: (1)
0 Kudos
Reply
3 Replies
hcait
Nintex Newbie

Re: Nintex form does not recalculate calculated fields on form edit

Jump to solution

Hi Andrew,

We had the same issue with one of the releases and it was bug and this issue was fixed in the new release. What version are you on? Probably an update to a latest release will help.

View solution in original post

Reply
sojanm
Nintex Newbie

Re: Nintex form does not recalculate calculated fields on form edit

Jump to solution

Hi Andrew,

You can do a conditional calculation. If the field value is null then do the calculation, or get the data from the field.

If(IsNullOrEmpty (FldName), Sum(Control), FldName)

Reply
arobins
Nintex Newbie

Re: Nintex form does not recalculate calculated fields on form edit

Jump to solution

Yep. I went to the new version and it works fine now.

Thanks for the help.

Reply