cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

Nintex Workflows not starting after creating new item

Hi, 

today I had to realize, that our workflows, which are running for years, are not starting anymore when creating a new list item. 

Our system administrator told us, that wether patches were installed nor changes were applied to our systems.

Can you give me some advices where to look at?
I have tried to increase the log level to verbose, but I couldn't find any hints regarding the problem.

I don't get any error messages, it just won't start. 

Best,

Silvano 

0 Kudos
Reply
6 Replies
Workflow Hero

Re: Nintex Workflows not starting after creating new item

Hi,

Did you try republishing the workflow?

Regards,

Shrini

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Nintex Workflows not starting after creating new item

Hi,

Have you checked in Workflow settings ? 

Regards

Reva Eka Patria

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Nintex Workflows not starting after creating new item

Hi,

thanks for the fast replies!
I have checked the settings, while re-publishing the workflows.
It seems that they start but take a long time, like 45 minutes.

I have purged the WorkflowHistoryLists for the whole webcollection using NWADMIN and via the database procedure "PurgeWorkflowData". This helped a little bit, so that they now start after 8 minutes, but still, longer then before.

The server seems alright with enough RAM and hard disk space.

I have also tried to restart the Timer Job on the server and an iisreset.

Best,

Silvano

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Nintex Workflows not starting after creating new item

Hi Silvano,

Just to check what happens if you create a new workflow on a new list? Does it also behave the same way i.e doe sit take 8 minutes to trigger when a new item gets created or modified? Just trying to check if in general your environment has an issue or is it just that particular list?

Regards,

Shrini

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Nintex Workflows not starting after creating new item

Hi Shrini,

I have just created a new list with a new workflow and it ran directly after creating an item.

I may consider recreating the whole website including lists and workflows, if this is a possible solution.

There are 3 sites with approx. 40 lists including a workflow each.

Best
Silvano

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Nintex Workflows not starting after creating new item

Hi Silvano,

Yes looks like your list may be an issue.

before going into recreating an entirely new site as you may have to validate all the permissions, existing running workflows or also retest your stuff?

What happens if you create a new simple workflow on the existing list and make it start when any new item gets created or modified? What does it do ? Does it run after 8 mins or new simple wf runs quickly?

If that runs quickly you might want to delete your entire workflow and create the new one and re-publish .. again assuming you are first checking any existing running workflows already on the list .. and also you might loose the existing WF history.

Regards,

Shrini

Accept as Solution Reply