cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Nintex Workflow will not initiate when files emailed to library

Jump to solution

Hello,

 

I have a document library with inbound email configured but having issues with the Nintex workflow automatically initiating.  How can I get a Nintex workflow to initiate when documents are email to a document library?  I can manually start the workflow but the workflow will not start automatically and the "Start when items are created" is set to yes.    

 

SharePoint 2013 Enterprise

Nintex Workflow v 3.0.8

 

Thanks,

 

Scott

Labels: (1)
0 Kudos
Reply
9 Replies
Not applicable

Re: Nintex Workflow will not initiate when files emailed to library

Jump to solution

Hi Scott,

Can you verify if the workflow gets initiated when you add a new item manually instead of inbound mail. Please use your id instead of system account.

My guess is, when the item is added to the library by inbound mail, sharpeoint uses sytem account. Hence this might be the reason the workflow is not getting initiated.

0 Kudos
Reply
jan
Nintex Newbie

Re: Nintex Workflow will not initiate when files emailed to library

Jump to solution

Hi Scott,

As Nidish mentioned this is a result of workflows not being able to run as the SharePoint system account. How we get around this is to create a custom column on the document library that has a default value. We then setup the workflow to trigger when an item is modified and equals the default value. The first step in the workflow would be to change this default value to something else.

Reply
dan_stoll
Nintex Newbie

Re: Nintex Workflow will not initiate when files emailed to library

Jump to solution


hey Scott here is a little trick I've been using for years. (text grabbed from MSDN) and should work for 2013

 

You have check in SharePoint server setting if workflow trigger on email is enabled or not, and enable it.

Using STSADM 
Open the SharePoint 2010 Management Shell as administrator and run following command:

stsadm -o getproperty -pn declarativeworkflowautostartonemailenabled

Output should be:

 

<Property Exist="Yes" Value="yes" />PS

If Value of property is “No” you have to enable it by typing following command:

stsadm -o setproperty -pn declarativeworkflowautostartonemailenabled -pv true.
Using PowerShell

This property was somewhat easier to set using STSADM, however keep in mind that STSADM is being retired. PowerShell is the command line administration tool to use moving forward.

Open the SharePoint 2010 Management Shell as administrator and run the following to determine the value of the DeclarativeWorkflowAutoStartOnEmailEnabled property:

$spWebService = [Microsoft.SharePoint.Administration.SPWebService]::ContentService
$spWebService.DeclarativeWorkflowAutoStartOnEmailEnabled

If the Value of the property is "False" you have to enable it by typing the following commands:

$spWebService = [Microsoft.SharePoint.Administration.SPWebService]::ContentService
$spWebService.DeclarativeWorkflowAutoStartOnEmailEnabled = $true
$spWebService.Update()

Reply
Not applicable

Re: Nintex Workflow will not initiate when files emailed to library

Jump to solution

Is anyone aware of a work around for this? Due to corporate policy I am unable to change the server setting (our admins wont change it).

0 Kudos
Reply
jan
Nintex Newbie

Re: Nintex Workflow will not initiate when files emailed to library

Jump to solution

Hi Benjamin, check my response above, this workaround works as expected without running any powershell/stsadm commands

0 Kudos
Reply
Not applicable

Re: Nintex Workflow will not initiate when files emailed to library

Jump to solution

Thanks Jan, That worked great!

0 Kudos
Reply
vamsi1278
Nintex Newbie

Re: Nintex Workflow will not initiate when files emailed to library

Jump to solution

Those who dont have credentials to modify something at server level they can follow this approach to make the trigger on workflow. 

0 Kudos
Reply
jephro
Nintex Newbie

Re: Nintex Workflow will not initiate when files emailed to library

Jump to solution

Jan Groenendijk,

I am trying to follow your suggestion. But things still aren't working quite right.

  1. I have added a custom field to my list... named it WF_Check, type Number with a default value of 0.
  2. Built a workflow. Confgured it to "Start when items are modified" in the WF settings.
  3. And the first step in the workflow is to change the value of WF_Check to 1

Still, nothing happens when an email arrives in the List.

I can manually kick off the workflow. And I can manually create an item in the list, and it will start the workflow.

Any thoughts? Maybe I am not following you correctly.

By the way, we are on SP 2013 with Nintex Workflow 2013 v 3.1.9.0.

-JeffRo  

0 Kudos
Reply
lonesurvivor
Nintex Newbie

Re: Nintex Workflow will not initiate when files emailed to library

Jump to solution

Have you set a condition to check for the value of the custom field as @jan wrote? I tried it this day and it worked like he described. But I also would like to understand, why it does :-)

0 Kudos
Reply