cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

Nintex Workflow menu missing from Central Administration in SharePoint 2013

Jump to solution

Hello erveryone,

I just stumbled into a problem. I just download the latest release of Nintex Workflow from the community portal and put the installer on my only frontend server and ran it under the sharepoint service account. The installer ran just fine and I could deploy the solutions (all) successfully to the farm servers. But now no entries for Nintex workflow show up in central administration...

I did the

Enable-SPFeature -Identity "NintexWorkflowAdmin" -Url http://CentralAdminURL

from this post already. Without -force I get an error telling me it is already enabled. With -force it goes thorugh. In both cases no change.

Re-running the installer ... no luck. Extracting the setup und running the powershell install.ps1 ... no luck.

Is there anybody around with an idea? Any help is greatly appreciated.

Greetings from Germany,

Martin

Labels: (1)
Reply
4 Replies
Workflow Hero

Re: Nintex Workflow menu missing from Central Administration in SharePoint 2013

Jump to solution

Okay, what I figured out so far is that the developer license kindly provided by Nintex only runs on SharePoint servers having  the role WebFrontEnd. Unfortunately, my server was set up as application server. So the idea would be to change the server role.

Since I am running SharePoint 2013, this proves to be a little bit difficult. No cmdlet or setting in the central admin is available to me. Or at least I am unable to find it.

Please advice!

0 Kudos
Reply
Workflow Hero

Re: Nintex Workflow menu missing from Central Administration in SharePoint 2013

Jump to solution

It seems I got the Server role changed using some Magic powershell:

$Server = get-spserver [Server Name goes here]

$Server.role = "WebFrontEnd"

$Server.update()

restart-Computer

However, still no luck.

0 Kudos
Reply
Workflow Hero

Re: Nintex Workflow menu missing from Central Administration in SharePoint 2013

Jump to solution

Hi Martin,

I don't think just switching the server role by powershell will do the trick as web frontend servers need to run more services that Nintex is also relying to.

I don't understand the topology of your farm. Do you have a single server farm but set up the server as application server? Or do you have dedicated web frontend but also an application server.

I assume this is a fresh new Nintex installation on an otherwise already working SharePoint farm, right? Nintex installations on application servers are not necessary as SharePoint/Nintex workflows will only be executed on web front end servers.

So if you could describe the topology of your farm a bit better people might be able to help you.

Greetings back from Berlin and best regards

Enrico

0 Kudos
Reply
Workflow Hero

Re: Nintex Workflow menu missing from Central Administration in SharePoint 2013

Jump to solution

Okay, I got it worked out. My problem was, that I did not deploy the Nintex Workflow solution to the Central Administration web applicaton.

Here are the steps I got Nintex Workflow working with:

  1. Get your community account associated with your license. You may open a ticket to do so.
  2. Obtain a license. You may asked the support for a developer license, if you have a valid software assurance for your production environment.
  3. Download the latest software from the Nintex community portal.
  4. Run the installer on one of your front end servers (the one serving the web applications to the end users).
    • The Nintex Workflow core (nintexworkflow2013core.wsp) will be deployed globally by the setup.
  5. Deploy the Nintex Workflow solution (nintexworkflow2013.wsp) to your web applications.
    Caution: Deploy the solution to the web application hosting the Central Administraiton console as well!
  6. Check, if Nintex menu shows up in the Central Administration.
  7. Configure the Configuration database.
    Go to the Central Administration -> Nintex Workflow Management -> Database setup.
    I used the defaults.
  8. Configure a content database.
    Go to the Central Administration -> Nintex Workflow Management -> Database setup.
    I used the defaults, which use the same database as in the step above.
  9. Enable Workflows for the web applications
    Go to the Central Administraion -> Nintex Workflow Management -> Web Application activation
    I checked the "all content web applications" checkbox and clicked the "Active" button. However, this may not be appropriate, depending on the setup you are running.
  10. Build and run your first workflow.

These steps worked for me, at least.

Feel free to leave a comment on what I have missed.

Reply