cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

Nintex Workflow - Send Notification Error

Hi All,

After updating the Nintex Workflow to the latest release, all workflows that have 'Send Notification' action fails and workflow cannot be started manually as well. Anyone experienced the same?
I have placed a support call but just reaching out to the community to see whether anyone else have come across a similar situation and how you managed to resolve the issue please.

Looking at the error log, can see the below entry

UserAgent not available, file operations may not be optimized.    at Microsoft.SharePoint.SPFileStreamManager.CreateCobaltStreamContainer(....

Legacy Workflow Infrastructure    98d5    Unexpected    System.Threading.ThreadAbortException: Thread was being aborted.   
03/13/2017 14:05:11.49*    w3wp.exe (:0x0ED8)                  0x20E4    SharePoint Foundation             Legacy Workflow Infrastructure    98d5    Unexpected    ...ing replacement)     at Nintex.Workflow.HumanApproval.Message.GetResolvedEmailBody(String body, SPWeb web, NWContextDataCollection contextData, ConfigSettings configSettings, Approver approver, Boolean lazyApprovalEnabled)  

Legacy Workflow Infrastructure    98d5    Unexpected    ...   at Nintex.Workflow.Activities.SendMessageActivity.Execute(ActivityExecutionContext executionContext) 


Thanks in advance.


Shaju Samuel

Labels: (2)
0 Kudos
Reply
10 Replies
Workflow Hero

Re: Nintex Workflow - Send Notification Error

Hi,

which version did you install?

1. First thing to check after every update is the Nintex Database update status in Central Administration at Nintex Workflow Database Setup and see if there is a database update available. If so, perform the update by clicking "update now".

If there is no update now link, you'd be fine.

2. If there is no update available I'd go to the external mail settings and check if everything there seems to be ok.

3. I'd check that normal mail delivery works fine. To check you can just add a notification to any list. Adding a notification will send you an email that confirms you set up a new notification.

4. If that notification works, I'd check minimal functionality by creating a new workflow with just a single mail action that sends an email to myself.

How do you go following these steps?

Kind regards,

Enrico

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Nintex Workflow - Send Notification Error

Thank You Enrico for the response.

1) there is no Update to be done for the database. That was already applied as part of the installation.

2) Normal mail delivery works fine. I tested by creating a simple workflow with a single send notification task and it works fine.

3) all current workflows that were running when the software was updated, is sending the emails out . Only new ones, I cannot start as the workflow fails on 'Send Notification'. Workflow failed to start is the message I receive.

 I thought it could be because the 'From' account was a not a valid User in the Send Notification action. I changed it to valid AD user account but that did not help either.

Did an IIS reset as well.

Interestingly the workflow timer job looks like its stuck even after stopping and starting the services n number of times.

Grrrrrr...

Very Annoying ..waiting to hear from support .

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Nintex Workflow - Send Notification Error

Just to add another observation that that workflows with too many actions, the workflow fails to start. However, if the workflow only have few actions, it does start the workflow.

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Nintex Workflow - Send Notification Error

How many actions do you have in your workflow?

So the problem is not related to the notification action itself but to the size of your workflow?

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Nintex Workflow - Send Notification Error

It works with one action (Send Notification) but a very simple workflow with 20 actions (of that, few are 'Commit pending changes') the workflow stalls at Send Notification and does not progress further.

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Nintex Workflow - Send Notification Error

20 actions in a workflow shouldn't be any problem.

I see you're using a workflow variable. Could you log the value of that variable to the workflow history prior to sending the notification? I'd assume something is not right with that variable.

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Nintex Workflow - Send Notification Error

Hi Enrico

Just to give you an update. After a week of exchanging emails with Support, it appears to be the March build of Nintex Workflows to be the issue.

It was by chance, that we noticed, that the March build of NW was not listed on the downloads page. Sent an email to the Support and they came back with the below message. So its all good, will have to wait for the hot fix and hopefully that will fix the issue.


Thanks for you time Enrico in trying to resolve this issue appreciate your help.

We have Identified an issue with Nintex Workflow 2013 Build 3.2.2.0 and it has been retracted from the downloads page.

When a Send Notification action has complex HTML like complex tables etc this can cause problems with the workflow engine.

The previous build is now available but please be advised that there is no roll back process for Nintex Workflow due to changes in the database schema.

We are looking at having a hotfix release on the downloads page in about 12 hours from the time of this email.

Please download the hotfix release when it becomes available and update your build of Nintex Workflow.

https://community.nintex.com/community/installation/product-downloads

Accept as Solution Reply
Workflow Hero

Re: Nintex Workflow - Send Notification Error

Thanks for the update! I already wondered why they retracted the build.
I hope they get this fixed for you soon!

Kind regards,

Enrico

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Nintex Workflow - Send Notification Error

Yep been investigating this issue myself the last couple of days. It caused my web front server cpu to spike to 100% and for timer jobs to fail which stopped workflows in the queue from running.

Narrowed it down to the send email action with lots of HTML in it.

Looking to install fix ASAP.

Thanks for bringing it to their attention.

0 Kudos
Accept as Solution Reply