cancel
Showing results for 
Search instead for 
Did you mean: 
MattCC
Nintex Newbie

Nintex Live Forms will not publish after updating to 2.12.0.0

Jump to solution

The issue we are seeing is identical to the one discussed here.

The problem is the listed resolution to that issue is to upgrade to version 2.11.2.2 or later and we are having the issue show up after already updating to version 2.12.0.0 (latest version).

 

We updated to V2.12.0.0 yesterday as an initial attempt to fix what we now know was a TLS issue on the servers. Nintex Live had stopped polling for new form submissions a week or so ago and the heath status of the service gave errors with our connection to Nintex Live endpoints. After updating the servers to TLS 1.2 all services are green and giving the "all good" status. However, now we are running into the issue above of Nintex Live Forms failing to publish and Nintex Form data is still nnot not finding their way into the SharePoint lists.

 

This is a farm wide issue, and we have already done a number of things like bouncing IIS, and disabling and enabling the Nintex Live Service in CA. The only error message we can find in the logs related to the problem is the following;

 

 

0x2500	Nintex Forms                  	Front End                     	00000	Unexpected	Sending form to Nintex Live failed. Message: Procedure or function NLF_GetOnlineFormByItem has too many arguments specified.. 

 

 

No changes were made to the form settings themselves and as I mentioned before these worked fine for years up until a week ago or so.

We have a ticket open with support but I'm hoping maybe the community may have some suggestions or thoughts as well.

THANKS!

Labels: (1)
0 Kudos
Reply
1 Reply
MattCC
Nintex Newbie

Re: Nintex Live Forms will not publish after updating to 2.12.0.0

Jump to solution

After working with Nintex support we managed to get this resolved, although why it occurred we do not know.

It appeared that in our upgrade the database scheme for Nintex Forms did not upgrade as expected. A number of tables were missing including an important Versions database. Manually creating the versions table and then running the Powershell command to update Nintex forms helped us fix the issue.

View solution in original post

0 Kudos
Reply