cancel
Showing results for 
Search instead for 
Did you mean: 
plamping
Nintex Newbie

Nintex Forms rules not working

Jump to solution

Some of my rules on my form in Nintex Forms for Office 365 are suddenly no longer working.

 

The rules are simple and do this-

When

Is New Mode

Hide

 

and

When

Is Edit Mode

Disable

 

I simply want it to hide the field when the form is new and display (read only) when the form is in edit mode. The rules used to work but now they have no effect. They never hide the fields. They display the fields in read/write mode, not disabled (read only) mode.

 

I tried many different variations of the rules but nothing changes. It is like some other error on the page is causing the rules to not run.  I also tried hiding all the other fields but no effect.

 

One thing I noticed was some errors in the browser's debugging console:

FormsPart.aspx:186:354
SyntaxError: expected expression, got '<'
ReferenceError: fn59081ec4c3f145deb293da663b4273ee is not defined

 

No, I have not added any custom Javascript to the page, in case you were wondering.

Labels: (1)
Tags (3)
0 Kudos
Reply
4 Replies
Community Manager Community Manager
Community Manager

Re: Nintex Forms rules not working

Jump to solution

How many form rules are you using? 

How many controls are shaing those rules?

 

Any chance you can provide a screenshot of the form/rule or export?

0 Kudos
Reply
plamping
Nintex Newbie

Re: Nintex Forms rules not working

Jump to solution
I sent an export of the form to Nintex Support. They looked at it and could not identify the source of the problem, but said that the form had "duplicate rules" and they removed some and sent me a new form to import.

It works now, after re-connecting all the controls to my list columns. I do not know exactly which rules caused the problem, or how the duplicates go created. Maybe when I added fields and deleted them and added back, that somehow left some orphaned rules in place?

I now have 14 rules on the form and they are all working. When new users enter the form in New mode, they only see the basics, and after they save and the workflow runs to fill in the rest of the fields, the more advanced fields will display to anyone who opens the form in Edit mode.

"How many controls are sharing those rules?" I do not know. I was not aware that controls could share rules. How do you do that?
0 Kudos
Reply
philipplucas
Nintex Newbie

Re: Nintex Forms rules not working

Jump to solution

You should always use unique rules and apply them to mutliple controls if required. This way you can reduce the overall number of rules. To do that you have to open the rules pane in your forms designer first and check the "Show all" checkbox. All rules will be displayed now. Next you can select any control on your form, open the dropdown menu beside the required rules name and select "Add to selected controls".

 

applyrulestoselectedcontrols.PNG

0 Kudos
Reply
plamping
Nintex Newbie

Re: Nintex Forms rules not working

Jump to solution
Okay, that makes sense now. I will do that. I also was able to use that "Show all" option to find some orphaned rules and delete them.
0 Kudos
Reply