cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

Nintex Form tries to open but is grayed out

Jump to solution

Hi

Hope someone can help.

New Nintex forms installation on sharepoint 2013

When I click new item or edit an existing item the Nintex form opens to show information correctly however the form is grayed out and the form becomes

unresponsive. Oddly, sometimes the form opens just fine but most of the time it fails as described above,

I have tried deactivating and reactivating the Nintex Forms feature but this did not help

 

Cheers

Laurie

Labels: (2)
Tags (1)
0 Kudos
Reply
17 Replies
Workflow Hero

Re: Nintex Form tries to open but is grayed out

Jump to solution

Hi

I have more info about this problem.

It is due to the CSS element <div class="msdlgOverlay" with a display:blocked being called when the Nintex dialog opens.

I've sent a support request to Nintex but if anyone else has a quick workaround that would be helpful

Cheers

Laurie

0 Kudos
Reply
Workflow Hero

Re: Nintex Form tries to open but is grayed out

Jump to solution

Hi Laurie,

Are you running a custom theme in your Sharepoint? 

Thanks

Mike

0 Kudos
Reply
Workflow Hero

Re: Nintex Form tries to open but is grayed out

Jump to solution

Yes

0 Kudos
Reply
Workflow Hero

Re: Nintex Form tries to open but is grayed out

Jump to solution

I've also experienced this issue when the forms of the list are configured to be modal.

The issue appears randomly and it depends on the browser used (sometimes only in IE, sometimes only in Chrome...).

It is due to CSS and more precisely to the z-index property.

Do you experience the same behaviour ?

Let us know the feedback from Nintex support.

Thanks,

Caroline

0 Kudos
Reply
Workflow Hero

Re: Nintex Form tries to open but is grayed out

Jump to solution

Hi Caroline,Mike

Thanks for taking the time to reply.

My issue is to do with the grey shading that is applied when a pop up window appears i.e. a Nintex form is opened.

Sometimes the Form will remain greyed over.

I "fixed" my issue by using some custom CSS to disable the grey pop up. This fixed all my issues and now opening Nintex Forms works over slow connections and the sharepoint edit button opens the Form in edit mode correctly every time. Nintex engineers are looking at the issue and I will post their answer

Here is what I added to company Style library CSS file ( I know that !important is poor form)

div.ms-dlgOverlay {

display:none !important;

}

0 Kudos
Reply
Workflow Hero

Re: Nintex Form tries to open but is grayed out

Jump to solution

Awesome and thanks for sharing! I was going to suggest adding in some CSS but I wasn't sure what tag you'd have to accommodate.   Reason being I saw similar things happen when a custom theme was in place and usually the CSS is the culprit.

0 Kudos
Reply
Not applicable

Re: Nintex Form tries to open but is grayed out

Jump to solution

Your css trick saved me!

Though I'm surprised this hasn't been fixed in a hot fix yet...

0 Kudos
Reply
Not applicable

Re: Nintex Form tries to open but is grayed out

Jump to solution

We experienced this same issue, but we elected to keep the grey overlay so users cannot use the web content behind the dialog. We put in CSS to force the z-index so that it will not go over the dialog.

.ms-dlgOverlay

{

          z-index: 1500 !important;

}

Thanks for pointing me in the right direction though.

Reply
Workflow Hero

Re: Nintex Form tries to open but is grayed out

Jump to solution

From what I can tell, if 'Launch forms in a dialog' (Advanced list setting) is set to Yes, then JavaScript code runs and sets the z-index of ms-dlgOverlay to be greater than the preceeding div with the class ms-dlgContent. Within this ms-dlgContent div is the iframe that holds the Nintex form. Within the form itself, if you set a custom style to try to elevate the z-index of ms-dlgContent, decrease the z-index of ms-dlgOverlay or try to hide it all together, as it is within an iframe the CSS rules it will not trigger.

The simplest fix is to update the advanced settings of the list and specify that forms should not load in a dialog, but if you want to keep the forms loading in a dialog, then add the following Custom JavaScript to your form:

NWF$(document).ready(function(){

   parent.$('body').find('div.ms-dlgOverlay').css('z-index', '1500');

});

0 Kudos
Reply