cancel
Showing results for 
Search instead for 
Did you mean: 
andreapasutti
Nintex Newbie

Nintex Form Won't Override Default SharePoint Form

Jump to solution

I created a library from a template because it's part of a workflow process that an entire department uses. So I have to use this library because I have to use the workflow that gets published to this list (also part of the process). It's standard, I have to use it.

I created a Nintex form because I wanted to require fields that I can't require in SharePoint because my workflow won't run if I have required fields in my SharePoint library. When I upload a document, I keep getting the default SharePoint form and not my Nintex form. How do I override the SharePoint form? I thought this happened automatically when I publish a Nintex form. That has been my experience to date.

Reply
6 Replies
praios81
Nintex Newbie

Re: Nintex Form Won't Override Default SharePoint Form

Jump to solution

Hi Andrea,

I had a similar problem when I created a list from a template that has been created in another farm. I recreated my list in the end because I wasn't able to cure it by myself.

However a very similar problem seems to have been solved here:

 

Maybe it's also an appropriate solution for you.

Kind regards

Enrico

Reply
Highlighted
andreapasutti
Nintex Newbie

Re: Nintex Form Won't Override Default SharePoint Form

Jump to solution

In the end I had to recreate the list from scratch. Annoying.

0 Kudos
Reply
garypowelljones
Nintex Newbie

Re: Nintex Form Won't Override Default SharePoint Form

Jump to solution

If it helps anyone, in my scenario the defualt Editing page (standard SharePoint) was displayed, but Nintex form was displayed correctly on the Display Form.

The cause for me was that the 'EditForm.aspx' had been modified in the browser by a user.

Resolution:

  • Open the library EditForm.aspx in the browser
  • Edit the web part displayed (the edit form for the list / library)
  • Reset the web part properties back to default values (chrome = Default, height / width = auto, title = Default title)
  • Under the 'Miscellaneous' properties, ensure the 'Form Template Name' is NFListEditForm (for me it still retained 'DocumentLibraryForm')
  • 'OK' or 'Apply'
  • Stop Editing

After refresh, the Nintex form was correctly displayed.

I guess the same would apply if the Display Form (DispForm.aspx) is displaying the same issues with the Nintex form not being displayed.

‌ - thanks for the help

Reply
marcc
Nintex Newbie

Re: Nintex Form Won't Override Default SharePoint Form

Jump to solution

I only see an InfoPath Form Web Part there. That contains no 'miscellaneous' properties.

0 Kudos
Reply
daniel_j_riley6
Nintex Newbie

Re: Nintex Form Won't Override Default SharePoint Form

Jump to solution

I had this issue but in my particular circumstance the form kept reverting back to the InfoPath form.  The way I was able to fix my issue even though the Nintex form I created was published:

1. Go to the list library settings and click on "Form Settings"

1a. If you receive an message stating that "Internet Explore is required to use this feature"

1b. Click on the settings menu for IE and select "Compatibility View settings"

1c. Add the site

2. Select the second option "Use the Default SharePoint form"

2a. you could delete the InfoPath from from the server, if applicable.

3. Republish your form

 

These steps helped in my particular situation. 

 

The following website list steps in more detail: https://nicoleprestby.com/2018/02/09/replace-a-stubborn-infopath-form-with-a-nintex-form/

0 Kudos
Reply
lonesurvivor
Nintex Newbie

Re: Nintex Form Won't Override Default SharePoint Form

Jump to solution

@garypowelljones That helped me a lot! I would give you kudos if I could... Smiley Wink

0 Kudos
Reply