cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

NW2013 Convert Document action error

You've received the following error on the Convert Document workflow action - "Error converting document. Conversion jobs did not complete. 1 jobs failed. 0 jobs cancelled".

Converting a Word document to PDF

This same error can also appear in SharePoint 2013, and can be related to Word Automation Services running on a Domain Controller. See here for information http://social.technet.microsoft.com/Forums/windowsserver/en-US/7fe9b409-46ee-4974-b7ae-29eab15e1ab9/...

It is suggested that you run the Word Automation Services service on a separate SharePoint Server which is not a Domain Controller, and then convert your word document to PDF.

Converting an Excel document to PDF

The Nintex Workflow action, Convert a Document, is only for use with Microsoft Word Documents. If you try to convert an excel spread sheet to PDF, you will receive an error message "Error converting document. Conversion jobs did not complete. 1 jobs failed. 0 jobs cancelled".

If you have the enterprise edition of SharePoint and the enterprise edition of Nintex Workflow, there is another action called Query Excel Services you may use. This action will not let you output an excel file as a PDF, however, it will allow you to select some information from an Excel file and pass it to a workflow variable for use in the workflow.

If for example you need to tell someone the profit for the month, and that information is always in the cell "A25" you can use this action to show them this information without the entire Excel file.

If however, you need the entire file, there are a couple choices beyond the standard Nintex actions.

  1. Create a custom action yourself, or
  2. Buy a third party product that can be used with Nintex Workflow, such as Muhimbi - PDF Converter for SharePoint
Labels: (1)
Reply
1 Reply
Workflow Hero

Re: NW2013 Convert Document action error

I had the same error when converting a word document to PDF format.

In my case the problem was that after creating the Word Automation Service Application the service account running that application did not have permission to the content database of the web application where my word document was lying in.

After giving the service account dbowner permission to my intranet content database and performing an IISRESET the conversion was done correctly.

0 Kudos
Accept as Solution Reply