cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Multiple validation rules don't work properly

I am working on a form that I want to use validation rules for. I have a drop down menu where users can either select "Link" or "Document". If they select "Link" then they must complete the link field and if they select "Document" they must add at least 1 attachment.

 

I was using the following validation rule for on my link field:

equals(TypeOfReference, 'Link')

 

And I was using the following validation rule for me attachments field:

equals(TypeOfreference, 'Document')

 

These rules work fine, but it doesn't check to see if the Link or Attachments are empty so it won't let users submit the form. I have also tried the following rules but they will not work and allow users to submit the form when they haven't completed the necessary fields.

 

equals(TypeOfReference, 'Link') && IsNullOrEmpty({Self})

equals(TypeOfReference, 'Link') && {Self} == ""

 

I also have tried using custom JavaScript, but was having the same issue. Below is a screenshot of my form.

 

I posted this in the dev talk forum and other users have the same issue. I also tried the exact same rules but ran them as formatting rules and they worked properly so my best guess is that this is a bug with the validation rules.

Labels: (2)
Tags (1)
0 Kudos
Reply
2 Replies
Workflow Hero

Re: Multiple validation rules don't work properly

Hi Aaron,

when I gave the Hyperlink a name, I found that it still didn't come up in rules and more interestingly, in the Calculated Value control.

So it's possible that that control isn't supported in rules at this stage.  It's not something that I've looked into before.

But I would recommend you do two things.

1. contact support

2. put the request in on http://nintex.uservoice.com

Vadim

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Multiple validation rules don't work properly

Hi Vadim,

I share the same feeling about the fact that such named controls don't come up in rules and could be considered as an unsupported case.

But as the formula works on a formatting rule, why or how could it be different on a validation rule?

Could Nintex Support give some explanations?

0 Kudos
Accept as Solution Reply