cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

Multiple line of text with links are non-clickable on mobile forms

I've a form/workflow where I collect attachments on different stages through the workflow. I compile them into a mutliple line of text fields and display them as hyperlinks on the task forms.

The MLT fields are working fine on desktop task forms. once we converted the same task form to mobile, non of the hyperlinks on those MLT fields are clickable on mobile. 

I also noticed that the delegate link doesn't work on mobile. I thought it is just because delegation doesn't work on mobile. 

Is there a way to make links work on mobile forms from multiple line of texts (that contain multiple links)? 

Are links even supported on mobile at all?!

0 Kudos
Reply
12 Replies
Workflow Hero

Re: Multiple line of text with links are non-clickable on mobile forms

CC: Dan Burke‌ // Jonathan Butler // Also ... Andrew Glasser // Tom Castiglia 

Any thoughts around this? This is a question I haven't seen come up before, or even be required, but it's very required for one of our clients. Not sure if we need a different tag for mobile links? 

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Multiple line of text with links are non-clickable on mobile forms

Hi Christine Mikhaiel‌ - Just to confirm your question... Are you referring to a multi-line text field with rich text enabled and with hyperlinks in that rich text? (I have not tested this myself in Nintex Mobile, but I want to make sure I understood your question)

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Multiple line of text with links are non-clickable on mobile forms

Yeah, I think that's what she's referring to. (She's currently out of the office so I'm answering on her behalf  )

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Multiple line of text with links are non-clickable on mobile forms

Hi Tom Castiglia‌, I was doing some testing with Christine Mikhaiel‌ on this...  It appears that Nintex mobile will not make links clickable in plain text, rich text, or enhanced rich text. 

The only way I can get a link to be clickable in Nintex mobile is using a Hyperlink control, BUT this will not work with multiple URLs, which is a requirement for us.  Any ideas?

Thank you!!!

Accept as Solution Reply
Workflow Hero

Re: Multiple line of text with links are non-clickable on mobile forms

Did you try to put the Hyperlink control within a repeating section? 

Accept as Solution Reply
Workflow Hero

Re: Multiple line of text with links are non-clickable on mobile forms

Hyperlinks are not supported in Repeating Sections; the forms designer will not allow it. 

You can help us out by voting this up:

https://nintex.uservoice.com/forums/229406-2-nintex-forms-for-sharepoint/suggestions/35920006-repeat...

Accept as Solution Reply
Workflow Hero

Re: Multiple line of text with links are non-clickable on mobile forms

how does your links look like?

for me it works with eg. rich text control without any issue ...

I recall in the past I did something similar with calculated value control as well.

The MLT fields are working fine on desktop task forms. once we converted the same task form to mobile, non of the hyperlinks on those MLT fields are clickable on mobile. 

note that this might  be matter of the browser - desktop browsers usually recognize strings that resemble to links as an active content and make them clickable even if there is not respective/correct markup behind.

nintex mobile doesn't seems to be so smart in this regard, so you have to provide links with correct markup so that they are made clickable

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Multiple line of text with links are non-clickable on mobile forms

Thanks for testing Marian Hatala! Are you using Android or iOS?  This works for us in Android, however on an Apple phone/tablet no matter where you click in the control it will only open the first link. 

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Multiple line of text with links are non-clickable on mobile forms

I tested with android.

So you say it works now for you with first link whereas before it didn't work at all?

have you provided valid/correct mark up for links?

Have you tried with a html separator tag between single links? - like div, br, p...

or with some text snippet inbetween?

0 Kudos
Accept as Solution Reply