cancel
Showing results for 
Search instead for 
Did you mean: 
ZebAhmed
Nintex Newbie

Missing Nintex Workflow Constants from farm server

Jump to solution

I have inherited a SharePoint 2013 environment that makes heavy use of Nintex Worflow and Forms 2013 (on prem.)

 

One of these is a workflow that automatically sets up a Lync account for a new user. This stopped working recently; I assumed this was due to the fact that the SFB Server name had been changed recently (they did some upgrades.)

 

On checking the workflow itself I could only find a reference to the SFBServer workflow constant, problem is, it doesn't exist on any of the SharePoint servers we have. I found the attached image from the original notes the SharePoint dev made in terms of the workflow constants he had set up, and NONE of these exist anymore. Only 3 exist, and of those 3 only 2 are mentioned in the attached image.

Not too sure what has happened here so would love some assitance. Am I looking in the wrong place? Is there a way to bring them back?

Labels: (1)
Tags (1)
0 Kudos
Reply
11 Replies
Nintex Employee
Nintex Employee

Re: Missing Nintex Workflow Constants from farm server

Jump to solution
Hi,
Isnt the Workflow Constant that you are looking for the 4th one in your screen shot?
0 Kudos
Reply
ZebAhmed
Nintex Newbie

Re: Missing Nintex Workflow Constants from farm server

Jump to solution

Hi yes it is, what I'm saying is that the ones you see in the screenshot are now missing. Dissapeared. Gone. They don't exist anymore. That's a screenshot from the support documentation from back in 2016 when this was set up.

0 Kudos
Reply
Nintex Employee
Nintex Employee

Re: Missing Nintex Workflow Constants from farm server

Jump to solution
Opps,

Are you looking in Central Administration or from the Nintex Menu in the site settings?
0 Kudos
Reply
ZebAhmed
Nintex Newbie

Re: Missing Nintex Workflow Constants from farm server

Jump to solution

From Central Administration Smiley Happy

0 Kudos
Reply
ZebAhmed
Nintex Newbie

Re: Missing Nintex Workflow Constants from farm server

Jump to solution

Should also add that I checked under site settings as well to see if they were set at a site level (they weren't.) Accoding to the notes the developer made, seems like he did it at the farm level.

0 Kudos
Reply
Nintex Employee
Nintex Employee

Re: Missing Nintex Workflow Constants from farm server

Jump to solution

Not sure why they would disappear.
You can try find the root cause for this issue or you could just re-create them.
If you want to find the root cause you may need to contact Nintex Support support@nintex.com to look at the database etc where the constants are stored. If they were deleted it may be hard to find out by whom and when.

0 Kudos
Reply
ZebAhmed
Nintex Newbie

Re: Missing Nintex Workflow Constants from farm server

Jump to solution

We have a DBA, is there a way he can check? If so what steps would he need to follow?

0 Kudos
Reply
Nintex Employee
Nintex Employee

Re: Missing Nintex Workflow Constants from farm server

Jump to solution
Your DBA can look in the dbo.WorkflowConstants table in the Nintex Configuration database to see what constants are present.
If they are there it may mean that you cannot see them in SharePoint due to some sort of permissions issue.
0 Kudos
Reply
ZebAhmed
Nintex Newbie

Re: Missing Nintex Workflow Constants from farm server

Jump to solution

Thanks Simon. He extracted the table for me and all the missing entries are there. You mentioned it could be a permission issue for me not seeing them. I am set as the site colletion administrator (in central admin) so could you point me in the right direction in terms of what elevated permissions I need?

0 Kudos
Reply