cancel
Showing results for 
Search instead for 
Did you mean: 
Automation Master
Automation Master

Live Forms – The form is referencing a field that does not exist?

Jump to solution

I have an on-premise Nintex Form (2013) which is getting the following error when pushed to Live Forms for anonymous submission:

The form is referencing a field that does not exist. Please notify the form designer.

Are there any ways to troubleshoot this error? This form is working fine from inside the site. Here's a few notes on my specific form in case they factor into the Live Forms issue:

  1. The form references an external JS file
  2. The form uses background images referenced in Site Assets
  3. The form contains controls which are not connected to any column.
0 Kudos
Reply
2 Replies
Automation Master
Automation Master

Re: Live Forms – The form is referencing a field that does not exist?

Jump to solution

It looks like I was able to answer my own question here. The form where I was seeing the "The form is referencing a field that does not exist. Please notify the form designer" error was originally imported from a O365 Nintex Form. Here was my work-around for getting the live-forms error to disappear:

  1. Open the form in the form designer and delete all container panels.
  2. Open 'Live Settings' and uncheck publish to live forms.
  3. Publish the form
  4. Click 'undo' until all panels are recovered on your form
  5. Open 'Live Settings' and re-establish your live forms configuration.
  6. Publish the form

Frankly, I'm not sure how this series of steps resolved the issue, but I suspect it has to do with the .XML being carried over between versions of Nintex Forms.

Reply
Not applicable

Re: Live Forms – The form is referencing a field that does not exist?

Jump to solution

Just to add to the record for others who might be seeking different answers, I had the same error message "The form is referencing a field that does not exist. Please notify the form designer" but this form was not published to Live ever. What eventually was located, is that the task form was generating this error message because it had a "Form variable." This is different from Workflow variable. And at some point I was trying to pull and display some Workflow variables and created a Form variable. After the Form variable was deleted, no more error.

0 Kudos
Reply