cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

Lists not populating in Create item in another site action

I'm trying to use the "Create item in another site" action.  I select the site from the list just fine, but the List field doesn't populate and remains disabled.

I tried the option to manually enter the URL and clicked the refresh lists button but it said: Cannot access site.

Does anyone have suggestions as to what direction I need to head in to troubleshoot this issue?

Labels: (1)
0 Kudos
Reply
3 Replies
Workflow Hero

Re: Lists not populating in Create item in another site action

OK, I found out that I'm getting an error in the browser console:

Failed to load https://{TheUrlImTryingToCreateItemIn}/_vti_bin/Lists.asmx: Response to preflight request doesn't pass access control check: No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin '{TheURLImComingFrom}' is therefore not allowed access.

Does that added piece of information help trigger anyone's thoughts on this issue?

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Lists not populating in Create item in another site action

Brian - I am having this very same issue. Have you found the solution?

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Lists not populating in Create item in another site action

First, I consider this a work around, not a solution.  The reason is because you have to reduce your browser security to make it work.  With that said, here is how I did it:

1. Use Internet Explorer - I could not make this work in Chrome.

2. Click the gear icon, then select "Internet Options", then click your "Security" tab.

3. Select the Local Intranet zone. (this might be different for you depending on your situation.  I added my sites to the Local Intranet zone by selecting the zone, clicking the "Sites" button, then clicking "Advanced" button and adding sites).

4. Click "Custom level..." button.

5. Find the "Miscellaneous" section, then locate the "Access data sources across domains" setting.  Set it to Enable.

Doing this allowed me to edit the workflow action as you would expect to be able to do.

I think the official way to handle this is with CORS, but I'm struggling with how to do it.

0 Kudos
Accept as Solution Reply