cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Nintex Newbie

Line Breaks are gone after adding text to Multi Line

Hi everybody,

 

I have a Multi Line Column with:

 

A

B

C

 

To this Multiline Column I'd like to add a new row ("D").

I do this with "build string".

It work's great, BUT the "old" Line Breaks (between A / B and C) are gone and the result is:

 

ABC
D

 

Any idea what I'm doing wrong?

 

Thx!

Labels: (1)
0 Kudos
Reply
11 Replies
Highlighted
Automation Master
Automation Master

Re: Line Breaks are gone after adding text to Multi Line

@Kronwied ....what's the syntax in build string to append the value? 

 

  • In build string:
    1. Add your MLT column from Item property tab
    2. Add new line from common tab. You can also use line break HTML tag but make sure your MLT is not set for plain text, it should be atleast rich text
    3. Add your variable/value i.e. C 
0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Line Breaks are gone after adding text to Multi Line

Hi,

 

thank you for the answer. Currently it looks like this:

 

1.JPG

The Variable "Titel_Änderung_laufend" is the current value of the MLT column. I then add the break and the "new" value.

Problem is that the Line breaks in the Variable "Titel_Änderung_laufend" (so the old value) disapears after this task.

 

See screenshots attached before/after:

 

2.JPG3.JPG

 

Hope I could explain it right :)

 

Thx!

 

 

 

 

0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Line Breaks are gone after adding text to Multi Line

@kunalpatel Do you see any error in here? Thank you!

0 Kudos
Reply
Highlighted
Automation Master
Automation Master

Re: Line Breaks are gone after adding text to Multi Line

@Kronwied .....Your screenshot is little confusing for me due to language barrier.....but may I know what type of MLT list column you're having? Is it plain text, rich text or enhanced rich text?

0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Line Breaks are gone after adding text to Multi Line

@kunalpatel Enhanced rich text...

0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Line Breaks are gone after adding text to Multi Line

@kunalpatel Can it be that the task "string" deletes every Line Break?

 

0 Kudos
Reply
Highlighted
Automation Master
Automation Master

Re: Line Breaks are gone after adding text to Multi Line

@Kronwied ....I've tested on my end where I'm storing something in my workflow variable and appending it to my MLT column and it's working for me without any issue. I cannot re-create your issue !!!

0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Line Breaks are gone after adding text to Multi Line

@kunalpatel Thanks for the answer...!

Maybe I have another important info:

I'm creating the line breaks with "<br/>"

Maybe those are deleted with my string-task?

0 Kudos
Reply
Highlighted
Automation Master
Automation Master

Re: Line Breaks are gone after adding text to Multi Line

@Kronwied ...did you try using "new line" option under Common tab?

0 Kudos
Reply