cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

Item disappears when Workflow begins

Jump to solution

Hi,

I created a Workflow this morning that would send a Notification E-mail and Remove the current users access to the item, while granting access to another user, I also have a Commit pending Changes option at the end of this Workflow. Previously I had this set up as two separate Workflows, but theough that they were in the incorrect order as the notification did not always get delivered.

I diabled the 2 old Workflows and published the new workflow.

I have since received reports of the items where that workflow has been initiated have disappeared. I applied the workflow to an item and the item disappeared.

The notification e-mail sent with the link the item included (as per the Workflow) when I click on the item link in the e-mail an error appears advising that the item has been deleted or the name changed.

I have searched for the item using the search function, which has not resulted in anything, neither has looking in the Recycle Bin.

 

Can you please advise what I did to create this error and how I can avoid it in the future as well as where my items went.

Labels: (1)
Tags (1)
0 Kudos
Reply
4 Replies
Highlighted
Nintex Newbie

Re: Item disappears when Workflow begins

Jump to solution

Are you sure you have the right permissions to be able to see those items?

0 Kudos
Reply
Highlighted
Not applicable

Re: Item disappears when Workflow begins

Jump to solution

Absolutely

I own the site and am the site champion if there is some other permission I need I would be grateful for some assistance in understanding what level need and arranging it

My level is full access as well as all other permission groups

Thanks

Deb Hawkes

Motor Assessing

Business Performance Consultant

IAG

0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Item disappears when Workflow begins

Jump to solution

Okay, I guess the problem is the following: as you are changing the permissions of the item and removing all current users access, you are also  deleting your own permissions. Only the user you granted access to in your workflow is probably able to see the items.

 

With Full Control you cannot see items without sufficient permissions, with the site collection administrator permission you would be able to (but it brings along more responsabilities).

 

Try changing your workflow and make sure that when granting access, your own username is listed too. Publish the workflow again and run it on new items to test whether that was the problem.

View solution in original post

0 Kudos
Reply
Highlighted
Not applicable

Re: Item disappears when Workflow begins

Jump to solution

Thank you so much, what you said twigged for me, instead of granting permission to the group, I granted permission for the individual (the form has the same name as the group, thus causing confusion)

Again thank you so much

Thanks

Inspire, lead and motivate our people to excel and reach their full potential.

–––––––––––––––––––––––––––––––––––––––––––––

DEB HAWKES

BUSINESS PERFORMANCE CONSULTANT

NATIONAL MOTOR ASSESSING

SHORT TAIL CLAIMS

DIRECT INSURANCE

INSURANCE AUSTRALIA GROUP (IAG)

P +61 (0)3 9204 2465

F +61 (0)3 8804 9328

E debra.hawkes@iag.com.au<mailto:name.surname@iag.com.au>

0 Kudos
Reply