cancel
Showing results for 
Search instead for 
Did you mean: 
suniltamanekar
Nintex Newbie

Issue with "Run Parallel Actions"

Today I came across with an issue with "Run Parallel Actions" control in Nintex Workflow 2010.

I set two actions under "Run Parallel Actions" - 1.  Legal Review and 2. Compliance Review. The comments of both Legal and Compliance are stored in two different workflow variables.  On running the workflow I receive two email intimations.  I opened each mail and accessed form and gave comments.  It is observed that after "Run Parallel Action" loop only the content remains with only one variable which is accessed last and content of one variable gets deleted.  Within the loop I stored the contents of workflow variable in respective list variables.  Even the list variable contents gets deleted.

I am not sure how this is happening and whether this is the functionality of the action.  Can some body help me to resolve the issue or suggest some other action which can capture more than one workflow variables in task forms and stores permanently.

cheersSmiley Happy

Sunil 

Labels: (1)
0 Kudos
Reply
9 Replies
tbeduneau
Nintex Newbie

Re: Issue with "Run Parallel Actions"

How do you get comment ? Task form ?


I would consider something like both variables are initiated empty when form loads :

- you have VarA et VarB, both initalised at empty value

- the first branch set VarA and leave VarB empty

- the second branch set VarB and leave VarA empty

In this case, one of your two variables would be empty, whatever you do.

Maybe you should try to show both variables value on form to see what happens ?

0 Kudos
Reply
Automation Master
Automation Master

Re: Issue with "Run Parallel Actions"

Hello,

Can you screen shot your workflow?  It seems that you are running this parallel inside of a loop perhaps: " Within the loop I stored the contents of workflow variable in respective list variables."   It is very easy to overwrite information when using a loop, so I'd like to have a better feel for what you are doing by seeing it visually.


Thanks

Mike

0 Kudos
Reply
suniltamanekar
Nintex Newbie

Re: Issue with "Run Parallel Actions"

Hi Thomas and Mike,

Original WF segment was as below:

Screen shot of one of the Request Review where I store comment in Workflow variable.  This is settings in Task Form Multi Line control

Stored in List variable through "Set Field Value" as

But at last I get value for only side variables either Legal (Both WF and List variables) or Compliance (both WF and List variables)

Sunil

0 Kudos
Reply
tbeduneau
Nintex Newbie

Re: Issue with "Run Parallel Actions"

Maybe adding a "Commit pending changes" action after each update item could be worth trying....

0 Kudos
Reply
suniltamanekar
Nintex Newbie

Re: Issue with "Run Parallel Actions"

Tried, but did not work.

0 Kudos
Reply
achilles_aditya
Nintex Newbie

Re: Issue with "Run Parallel Actions"

Hi,

I had one issue with the parallel conditions. Following are the things that I think are causing the error

  • There are two branches in your workflow and the workflow works when both the conditions are satisfied i.e. Both compliance and Legal review required are yes
  • If any of the condition is no then Request review and Set field value wont be executed for other branch also.

If this is your issue then its the default behavior of the Nintex Parallel Actions

0 Kudos
Reply
Automation Master
Automation Master

Re: Issue with "Run Parallel Actions"

Thanks Sunil, can you elaborate what you meant by "loop" in your original post?   

0 Kudos
Reply
suniltamanekar
Nintex Newbie

Re: Issue with "Run Parallel Actions"

Hi Aditya,

In my case both the conditions were True.  But still the issue.  I think this is the default behavior of Run Parallel Action.

Hi Mike,

Loop word I used for "Run Parallel Action" and other actions under it.

Cheers:

Sunil

0 Kudos
Reply
mdom
Nintex Newbie

Re: Issue with "Run Parallel Actions"

Hi,

I am also having this problem.

If this was default behavior it would be consistent, I have another workflow with about 8 separate tasks, the comments work fine with those. - I will try copying a snippet from an existing workflow to see if the problem persists.

But even any new workflows I create seem to have this issue.

The last task to be completed will save the variables but the first will not.

Have also tried one task form.

Will have a play around and try to sort this out but any advice would be greatly appreciated. Confirmation that this is how parallel actions work would also be appreciated though again it was not working like this previously..

0 Kudos
Reply