cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

Issue with Email Not Being Sent depending on prior action

I am experiencing a strange issue where sometimes the Send an Email action completes but no email is actually sent. Prior to the email being sent there is a To Do Task action - the email will send if some users complete this task, but when other users complete the preceding task it does not send.

Example 1:

User A starts the workflow

User A completes the To Do Task

Email is successfully sent

Example 2:

User A starts the workflow

User B completes the To Do Task

Email is NOT SENT, although the action and workflow are completed without error.

This is happening in a large workflow.

I have created a second test workflow that just has the To Do Task followed by Send an Email and the behaviour is exactly the same.

Given that the workflow is running under User A in both cases, how can the difference in the email behaviour be explained.

This relates to NW2013 on-prem.

Labels: (2)
0 Kudos
Reply
5 Replies
Workflow Hero

Re: Issue with Email Not Being Sent depending on prior action

Have you checked for the affected users that there is an email address associated with them? If you cc yourself in on the email see what email address the workflow is trying to send to? 

Accept as Solution Reply
Workflow Hero

Re: Issue with Email Not Being Sent depending on prior action

what happens if you remove to do task and let the workflow just send notification?

Accept as Solution Reply
Workflow Hero

Re: Issue with Email Not Being Sent depending on prior action

How are you populating the "To" field in the Send Notification?  I'm assuming it's a variable of some sort?

Accept as Solution Reply
Workflow Hero

Re: Issue with Email Not Being Sent depending on prior action

Hi Casey. The email is always being sent to the same static address. In example 1 the email is sent. In example 2 the email is not sent. The issue is not with the email address itself.

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Issue with Email Not Being Sent depending on prior action

The To field is the Title column in my test list. In each of the examples above I am running the workflow on the same item so the email address is the same.

0 Kudos
Accept as Solution Reply