cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

Getting "Error in Task. The user to assign the task to has resolved as blank text." error when I attempt to assign the task to an e-mail group.

I have a workflow that assigns a flexi-task to an outlook e-mail group for each store calculated based on a dropdown list. It has to send individually addressed e-mails so anyone in the group can complete the task. 

However, when it sends the task out it has the below error (oddly our test group and one of the stores groups work fine). 

A screenshot of the error

I've tried changing the e-mail group to a variable, and I've tried adding a pause to the workflow.  On the list, the e-mail group is being correctly identified and it's not blank. 

What might be causing this?

Labels: (2)
Tags (1)
0 Kudos
Reply
11 Replies
emha
Nintex Newbie

Re: Getting "Error in Task. The user to assign the task to has resolved as blank text." error when I attempt to assign the task to an e-mail group.

what you mean with 'outlook e-mail group'?

you can only assign a task to AD security group or sharepoint group.

0 Kudos
Reply
cassymfreeman
Nintex Newbie

Re: Getting "Error in Task.  The user to assign the task to has resolved as blank text." error when I attempt to assign the task to an e-mail group.

So you're assigning to a sharepoint group and have ticked the assign individual tasks? Can you show some screenshots of how you populate the flexi task assignee (you said based on a lookup)?

0 Kudos
Reply
Not applicable

Re: Getting "Error in Task.  The user to assign the task to has resolved as blank text." error when I attempt to assign the task to an e-mail group.

Yeah, so I have a list of our stores and their e-mail groups, and whichever store is selected gets the inquiry.  This works for the paths that don't require a flexi-task response. 

Here's where it sets the variable to the e-mail, and the stores are set up as Sharepoint groups.  

Then it assigns the flexitask to the variable.

The task will successfully send to some groups and not others. 

0 Kudos
Reply
emha
Nintex Newbie

Re: Getting "Error in Task. The user to assign the task to has resolved as blank text." error when I attempt to assign the task to an e-mail group.

could you post example of Email field content?

and clarify what type of groups are defined there - sharepoint group, AD security group, AD distribution group, ....

btw, why do you have there that extra (space? and) semicolon in assignee field?

it's not needed, and I would say it may rather cause problems.

0 Kudos
Reply
cassymfreeman
Nintex Newbie

Re: Getting "Error in Task.  The user to assign the task to has resolved as blank text." error when I attempt to assign the task to an e-mail group.

ok so looks like you are setting variable value to "e-mail" on current item? If that is the case why not set the assignee to the current item properly "e-mail"? Or is your set variable incorrectly configured? Should "current item" be changed to "stores list" choosing email where X = X? I may have completely misunderstood and hope I'm not adding more confusion to the matter...

0 Kudos
Reply
Not applicable

Re: Getting "Error in Task. The user to assign the task to has resolved as blank text." error when I attempt to assign the task to an e-mail group.

The e-mail field is the direct e-mail address for the store in testing it's VCS000@va.gov, which is an AD Distribution group with myself and other people on the test project.

So, in the above example it'd assign the task to members of VCS000@va.gov individually.  It works for the test location and the store on site, but e-mail groups offsite don't seem to work (it could be a locality based issue).

As far as the space and semicolon, Nintex just adds that automatically when I put a reference into that box.

0 Kudos
Reply
Not applicable

Re: Getting "Error in Task. The user to assign the task to has resolved as blank text." error when I attempt to assign the task to an e-mail group.

I've found sometimes setting things as variables works when having them directly reference the original fields does not.  For some reason having a degree of separation occasionally makes it work (no idea why). 

0 Kudos
Reply
emha
Nintex Newbie

Re: Getting "Error in Task. The user to assign the task to has resolved as blank text." error when I attempt to assign the task to an e-mail group.

does 'offsite groups' mean external emails ie. not within your active directory domain?

0 Kudos
Reply
Not applicable

Re: Getting "Error in Task.  The user to assign the task to has resolved as blank text." error when I attempt to assign the task to an e-mail group.

I'm not sure how to tell which e-mails are in the active directory domain.  They're all VA employees in the VA outlook system, it doesn't go to any private e-mail addresses or groups.

When I'm talking about offsite groups I mean other physical locations.  The Sharepoint tasks sent to people in my local geographical area work, but if I try and send them to Kansas (for example) they error.

0 Kudos
Reply