cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

Error when trying to detach Nintex 2013 Content DB - "Server name not specified."

Jump to solution

I'm trying to detach a Nintex 2013 content DB using the following command:

NWAdmin.exe -o DetachDatabase -serverName ContentSQL -databaseName NW_Portals

However I'm receiving the following error:

Server name not specified.

Check operation usage:

NWAdmin.exe -o DetachDatabase -serverName serverName [-databaseName contentDatabase]

Has anyone seen this issue before?

Labels: (1)
0 Kudos
Reply
6 Replies
Highlighted
Nintex Newbie

Re: Error when trying to detach Nintex 2013 Content DB - "Server name not specified."

Jump to solution

Do you need a FQDN for your sql server ContentSQL ?

0 Kudos
Reply
Highlighted
Not applicable

Re: Error when trying to detach Nintex 2013 Content DB - "Server name not specified."

Jump to solution

ContentSQL is a SQL alias so shouldn't need a FQDN. I originally attached the DB using the below so not sure what's different about detaching.

NWAdmin.exe -o AttachDatabase -serverName ContentSQL -databaseName NW_Portals -integrated

0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Error when trying to detach Nintex 2013 Content DB - "Server name not specified."

Jump to solution

Hi Luke,

This might sound odd but did you type the command on the PS window rather than pasting it? I have seen instances where it probably puts in characters and hence the command doesn't recognize itself.

I had a quick look inside the assembly (dotPeek) and the error is put out only when it does not find the server name, the authentication etc comes in later .. so really cant think of anything else other than you could type the command or try to see if it can see any other SQL server?

Regards,

Shrini

View solution in original post

0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Error when trying to detach Nintex 2013 Content DB - "Server name not specified."

Jump to solution

Luke,

Did that work for you?

Shrini

0 Kudos
Reply
Highlighted
Not applicable

Re: Error when trying to detach Nintex 2013 Content DB - "Server name not specified."

Jump to solution

Yeah it did thanks. It's strange that there wasn't the same issue with the attach command.

0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Error when trying to detach Nintex 2013 Content DB - "Server name not specified."

Jump to solution

cheers,

Glad it helped..

Shrini

0 Kudos
Reply