cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Nintex Newbie

Error when trying to access inventory after a contentDB split

Hello,

 

Our main Nintex content DB had been splitted to help us to migrate Sharepoint site from Sharepoint 2010 to Sharepoint 2019 one by one.

 

During this process, first of all we stopped the web sites and stop the sptimerv4.

Then we splitted the main Nintex contentDB into several ones (one by application) using the following commands for each application :

.\nwadmin.exe -o moveData -Url <url to a specific app> -SourceDatabase <main Nintex contentDB connection string>  -TargetDatabase <splitted Nintex contentDB connection string>

Finally the web sites and SPTIMERV4 service were restarted.

(The split was made on Sharepoint 2010 servers)

On top of that each splitted site is mapped to its own splitted content DB. And they all appear in the list of databases.

 

After several days, our team tried to get workflows inventory, but the page is in error (in every sites using Nintex, not just splitted ones).ULS logsULS logs

 

 

 

 

 

 

In fact it says that the current login doesn't have access to a specific Nintex content DB. More specifically this Nintex Content DB one of the splitted content DB.

And it affects not just the splitted applications but the other one using the main content DB too.

The problem is just happening in the workflows inventory for the moment.

 

Do you have any idea of this bug ? Or maybe something that was badly done during the splitting process ? Please.

 

Thanks in advance.

Labels: (2)
0 Kudos
Reply
1 Reply
Highlighted
Nintex Employee
Nintex Employee

Re: Error when trying to access inventory after a contentDB split

Hi,

The correct process for migrating from SharePoint 2010 to SharePoint 2019 is to migrate to 2013 first and then 2016 and then 2019.
Doing this will give you a seamless migration.
0 Kudos
Reply